aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-10-07 17:52:37 -0700
committerKhem Raj <raj.khem@gmail.com>2023-10-07 17:53:55 -0700
commit29644952a6555849274b8ef8a8bd9fba2658dd76 (patch)
tree99d526ce1bfb951d513cae1fa8b84bee771dec83 /meta-oe
parent9ef26775a5d9afad5277c8ef6c1f3332e4bbdf10 (diff)
downloadmeta-openembedded-29644952a6555849274b8ef8a8bd9fba2658dd76.tar.gz
libnvme: Fix test builds on musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Cc: Christophe Vu-Brugier <christophe.vu-brugier@seagate.com>
Diffstat (limited to 'meta-oe')
-rw-r--r--meta-oe/recipes-support/libnvme/libnvme/0001-ioctl-Check-for-ioctl-signature-for-musl.patch38
-rw-r--r--meta-oe/recipes-support/libnvme/libnvme_1.6.bb4
2 files changed, 41 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libnvme/libnvme/0001-ioctl-Check-for-ioctl-signature-for-musl.patch b/meta-oe/recipes-support/libnvme/libnvme/0001-ioctl-Check-for-ioctl-signature-for-musl.patch
new file mode 100644
index 0000000000..06f7b57121
--- /dev/null
+++ b/meta-oe/recipes-support/libnvme/libnvme/0001-ioctl-Check-for-ioctl-signature-for-musl.patch
@@ -0,0 +1,38 @@
+From ad1ac4215f051bd42b7ddf64dad63d8215cc3ac4 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 7 Oct 2023 17:50:54 -0700
+Subject: [PATCH] ioctl: Check for ioctl signature for musl
+
+Fixes
+../git/test/ioctl/mock.c:117:5: error: conflicting types for 'ioctl'
+ 117 | int ioctl(int fd, unsigned long request, ...)
+ | ^
+/mnt/b/yoe/master/build/tmp/work/cortexa15t2hf-neon-yoe-linux-musleabi/libnvme/1.6/recipe-sysroot/usr/include/sys/ioctl.h:115:5: note: previous declaration is here
+ 115 | int ioctl (int, int, ...);
+ | ^
+
+Upstream-Status: Pending
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ test/ioctl/mock.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/test/ioctl/mock.c b/test/ioctl/mock.c
+index e917244..7d5c983 100644
+--- a/test/ioctl/mock.c
++++ b/test/ioctl/mock.c
+@@ -114,7 +114,11 @@ void end_mock_cmds(void)
+ } \
+ })
+
++#if defined(__linux__) && !defined(__GLIBC__)
++int ioctl(int fd, int request, ...)
++#else
+ int ioctl(int fd, unsigned long request, ...)
++#endif
+ {
+ struct mock_cmds *mock_cmds;
+ bool result64;
+--
+2.42.0
+
diff --git a/meta-oe/recipes-support/libnvme/libnvme_1.6.bb b/meta-oe/recipes-support/libnvme/libnvme_1.6.bb
index 37e5d63011..26ad36d7d0 100644
--- a/meta-oe/recipes-support/libnvme/libnvme_1.6.bb
+++ b/meta-oe/recipes-support/libnvme/libnvme_1.6.bb
@@ -13,7 +13,9 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c \
DEPENDS = "json-c"
SRCREV = "37a803cf77e224f66d86b1e1d9e74a15f55ea600"
-SRC_URI = "git://github.com/linux-nvme/libnvme;protocol=https;branch=master"
+SRC_URI = "git://github.com/linux-nvme/libnvme;protocol=https;branch=master \
+ file://0001-ioctl-Check-for-ioctl-signature-for-musl.patch \
+"
S = "${WORKDIR}/git"