aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test
diff options
context:
space:
mode:
authorTymoteusz Burak <tymoteusz.burak@3mdeb.com>2023-08-23 10:53:10 +0200
committerKhem Raj <raj.khem@gmail.com>2023-08-26 17:32:45 -0700
commit50b820e18e24a964853747ab65608a7a2d96717d (patch)
tree0249ae1240450f9c973a9a94f354599817a443e0 /meta-oe/recipes-test
parent54e11a6c5b169454cab60c7e6a1da8930d42b495 (diff)
downloadmeta-openembedded-50b820e18e24a964853747ab65608a7a2d96717d.tar.gz
libfaketime: add recipe
This commit adds the libfaketime library recipe, which provides time manipulation capabilities for testing and debugging purposes. libfaketime allows developers to modify the system time reported to applications, aiding in scenarios where accurate time emulation is required. I deleted the extra flags altogether as they seem to be only necessary for old versions of this project (0.9.6). CC: Khem Raj <raj.khem@gmail.com> Signed-off-by: Tymoteusz Burak <tymoteusz.burak@3mdeb.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-test')
-rw-r--r--meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
new file mode 100644
index 0000000000..7500e57658
--- /dev/null
+++ b/meta-oe/recipes-test/libfaketime/libfaketime_0.9.10.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "A library for faking the system time in user-space programs"
+SECTION = "libs"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+SRCREV = "d475b925943ad404c6c728ac868dc73949e7281c"
+SRC_URI = "\
+ git://git@github.com/wolfcw/libfaketime.git;branch=master;protocol=https \
+ "
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+do_compile () {
+ oe_runmake
+}
+do_install () {
+ install -d ${D}${libdir}/faketime
+ oe_libinstall -C src libfaketime ${D}${libdir}/faketime
+ install -d ${D}${bindir}
+ install -m 0755 src/faketime ${D}${bindir}
+}
+
+PACKAGES =+ "lib${PN}"
+
+FILES:${PN} = "${bindir}/faketime"
+FILES:lib${PN} = "${libdir}/faketime/*"
+
+INSANE_SKIP:${PN} += "dev-so"
+INSANE_SKIP:lib${PN} += "dev-so"