aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-shells
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-04-05 01:36:40 +0200
committerKhem Raj <raj.khem@gmail.com>2023-04-05 15:56:47 -0700
commit9f6268e283e291e6ac0b5aabefd8c98326e7522e (patch)
tree49a1490c7f0b1f46b9651328a2afb9dd75c7ecb6 /meta-oe/recipes-shells
parent6e4063c1d8d2ffb780664c5cd142f90f96a8a56a (diff)
downloadmeta-openembedded-9f6268e283e291e6ac0b5aabefd8c98326e7522e.tar.gz
zsh: fix installed-vs-shipped with multilib
* fixes: lib32-zsh-5.8: lib32-zsh: Files/directories were installed but not shipped in any package: /usr/share/lib32-zsh /usr/share/lib32-zsh/5.8 /usr/share/lib32-zsh/site-functions /usr/share/lib32-zsh/5.8/functions /usr/share/lib32-zsh/5.8/functions/_selinux_users ... 1000+ lines ... /usr/share/lib32-zsh/5.8/functions/VCS_INFO_bydir_detect Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. lib32-zsh: 1116 installed and not shipped files. [installed-vs-shipped] * they will clash if someone is trying to install both zsh and lib32-zsh, but it's not very likely as nobody sane was building lib32-zsh with 1000+ line warning regularly Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-shells')
-rw-r--r--meta-oe/recipes-shells/zsh/zsh_5.8.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-shells/zsh/zsh_5.8.bb b/meta-oe/recipes-shells/zsh/zsh_5.8.bb
index b023e8d297..7602ff9f64 100644
--- a/meta-oe/recipes-shells/zsh/zsh_5.8.bb
+++ b/meta-oe/recipes-shells/zsh/zsh_5.8.bb
@@ -22,8 +22,8 @@ inherit autotools-brokensep gettext update-alternatives manpages
EXTRA_OECONF = " \
--bindir=${base_bindir} \
--enable-etcdir=${sysconfdir} \
- --enable-fndir=${datadir}/${PN}/${PV}/functions \
- --enable-site-fndir=${datadir}/${PN}/site-functions \
+ --enable-fndir=${datadir}/${BPN}/${PV}/functions \
+ --enable-site-fndir=${datadir}/${BPN}/site-functions \
--with-term-lib='ncursesw ncurses' \
--with-tcsetpgrp \
--enable-cap \