aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/makedumpfile
diff options
context:
space:
mode:
authorAlexander Kamensky <alexander.kamensky42@gmail.com>2020-11-12 11:58:36 -0800
committerKhem Raj <raj.khem@gmail.com>2020-11-12 16:13:45 -0800
commitb1cae56126b4cfa6a03520a9ccd044ad8b5fcfb0 (patch)
tree8931610a528f920aeeb006afc5165f03b062c812 /meta-oe/recipes-kernel/makedumpfile
parent7a6a1ac1d3cddeea7828a59ddacc194dc724cae8 (diff)
downloadmeta-openembedded-b1cae56126b4cfa6a03520a9ccd044ad8b5fcfb0.tar.gz
makedumpfile: add PACKAGECONFIG options for lzo and snappy compression
makedumpfile can be compiled with lzo and/or snappy dump file compression support. Lzo and snappy offer faster compression time but slightly bigger compressed files. When reload time is important it might be beneficial to use lzo or snappy compression. But it brings additional dependencies and can make crash image bigger. Add makedumpfile PACKAGECONFIG that would allow to add lzo and/or snappy if so desired. Signed-off-by: Alexander Kamensky <alexander.kamensky42@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-kernel/makedumpfile')
-rw-r--r--meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.7.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.7.bb b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.7.bb
index 165e192cb1..ad1e09c350 100644
--- a/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.7.bb
+++ b/meta-oe/recipes-kernel/makedumpfile/makedumpfile_1.6.7.bb
@@ -40,8 +40,13 @@ SECTION = "base"
EXTRA_OEMAKE = "\
LINKTYPE=static \
TARGET=${TARGET_ARCH} \
+ ${PACKAGECONFIG_CONFARGS} \
"
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[lzo] = "USELZO=on,USELZO=off,lzo"
+PACKAGECONFIG[snappy] = "USESNAPPY=on,USESNAPPY=off,snappy"
+
do_install () {
mkdir -p ${D}/usr/bin
install -m 755 ${S}/makedumpfile ${D}/usr/bin