aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2023-12-31 13:23:07 +0100
committerKhem Raj <raj.khem@gmail.com>2023-12-31 08:27:47 -0800
commitb46ee0ca65fbcb3942ffe1a806fe0451ed672c53 (patch)
treef38a4a0edfeb82a2a2fb37cfa98444013ac5cb4b /meta-oe/recipes-graphics
parent30b37bb09ee52cb113c39844d92eb4aaabeb0833 (diff)
downloadmeta-openembedded-b46ee0ca65fbcb3942ffe1a806fe0451ed672c53.tar.gz
fontforge: add a readline PACKAGECONFIG
This helps with build determinism; also if readline is not in sysroot but readline-native is, fontforge erroneously decides to build with it. Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb
index 404e86b86a..31dd495fd7 100644
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20230101.bb
@@ -24,6 +24,8 @@ SRC_URI = "git://github.com/${BPN}/${BPN}.git;branch=master;protocol=https \
S = "${WORKDIR}/git"
EXTRA_OECMAKE = "-DENABLE_DOCS=OFF"
+PACKAGECONFIG = "readline"
+PACKAGECONFIG[readline] = "-DENABLE_READLINE=ON,-DENABLE_READLINE=OFF,readline"
CFLAGS += "-fno-strict-aliasing"
LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"