aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorChristian Eggers <ceggers@arri.de>2020-06-09 08:32:09 +0200
committerKhem Raj <raj.khem@gmail.com>2020-06-10 20:55:27 -0700
commita661a41606d0f0b4bac1665c29ba7d5c7e6ef486 (patch)
treed4e725518b2949c6bfedabf696c1cda362aac751 /meta-oe/recipes-graphics
parent1d6071e97157851dbfbdf26f302fc5ec8f6ee4db (diff)
downloadmeta-openembedded-a661a41606d0f0b4bac1665c29ba7d5c7e6ef486.tar.gz
graphviz: Extend for nativesdk
The "dot" tool is often used together with doxygen which is already available for nativesdk. Cross compiling graphviz for nativesdk looks quite similar as building for target. At installation time of the SDK, "dot -c" must be called in order to create <SDK sysroot>/usr/lib/graphviz/config6. Signed-off-by: Christian Eggers <ceggers@arri.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/graphviz/graphviz/graphviz-setup.sh6
-rw-r--r--meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb24
2 files changed, 29 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz/graphviz-setup.sh b/meta-oe/recipes-graphics/graphviz/graphviz/graphviz-setup.sh
new file mode 100644
index 0000000000..df0be9e3ed
--- /dev/null
+++ b/meta-oe/recipes-graphics/graphviz/graphviz/graphviz-setup.sh
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+echo "Setting up graphviz..."
+
+# Create /usr/lib/graphviz/config6
+$OECORE_NATIVE_SYSROOT/usr/bin/dot -c
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
index 12ecb99091..aa5c0c8206 100644
--- a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
+++ b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb
@@ -16,6 +16,7 @@ DEPENDS = " \
freetype \
"
DEPENDS_append_class-target = " ${BPN}-native"
+DEPENDS_append_class-nativesdk = " ${BPN}-native"
inherit autotools-brokensep pkgconfig gettext
@@ -33,6 +34,10 @@ SRC_URI_append_class-target = "\
file://0001-Use-native-mkdefs.patch \
file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \
"
+SRC_URI_append_class-nativesdk = "\
+ file://0001-Use-native-mkdefs.patch \
+ file://graphviz-setup.sh \
+"
SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072"
SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a"
@@ -47,7 +52,17 @@ EXTRA_OECONF_class-target = "\
--disable-r \
--disable-sharp \
"
+EXTRA_OECONF_class-nativesdk = "\
+ --with-expatincludedir=${STAGING_INCDIR} \
+ --with-expatlibdir=${STAGING_LIBDIR} \
+ --without-included-ltdl \
+ --disable-java \
+ --disable-tcl \
+ --disable-r \
+ --disable-sharp \
+ "
CFLAGS_append_class-target = " -D_typ_ssize_t=1 -D_long_double=1"
+CFLAGS_append_class-nativesdk = " -D_typ_ssize_t=1 -D_long_double=1"
do_configure_prepend() {
cd ${S}
# create version.m4 and ignore libtoolize errors
@@ -59,6 +74,13 @@ do_install_append_class-native() {
install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir}
}
+do_install_append_class-nativesdk() {
+ # graphviz-setup.sh must be executed at SDK installation
+ install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d
+ install -m 0755 ${WORKDIR}/graphviz-setup.sh ${D}${SDKPATHNATIVE}/post-relocate-setup.d
+}
+FILES_${PN}_class-nativesdk += "${SDKPATHNATIVE}"
+
PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo"
FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/"
@@ -74,4 +96,4 @@ INSANE_SKIP_${PN}-python = "dev-so"
FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"