aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorChristophe Chapuis <chris.chapuis@gmail.com>2024-03-16 11:00:51 +0100
committerKhem Raj <raj.khem@gmail.com>2024-03-17 13:10:11 -0700
commit9e136f0043148a0e382a58ec1e821944be047628 (patch)
tree183c7e407cd9cc0a70c829b83cbb803901631ace /meta-oe/recipes-graphics
parent910614b4b30537f7729fec5ea2ed742299e1875d (diff)
downloadmeta-openembedded-9e136f0043148a0e382a58ec1e821944be047628.tar.gz
lvgl: install lv_conf.h
Add an install append to copy the generated lv_conf.h as part of the lvgl package, so that it will be found and used by the recipes that want to use lvgl. Signed-off-by: Christophe Chapuis <chris.chapuis@gmail.com> Reviewed-by: Marek Vasut <marex@denx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb b/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
index 8d08485089..3dbf818c82 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
@@ -27,6 +27,11 @@ ALLOW_EMPTY:${PN} = "1"
PACKAGECONFIG ??= "drm"
require lv-conf.inc
+do_install:append() {
+ install -d "${D}${includedir}/${PN}"
+ install -m 0644 "${S}/lv_conf.h" "${D}${includedir}/${PN}/lv_conf.h"
+}
+
FILES:${PN}-dev += "\
${includedir}/${PN}/ \
${includedir}/${PN}/lvgl/ \