aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2023-12-26 15:00:33 +0800
committerKhem Raj <raj.khem@gmail.com>2023-12-29 09:04:17 -0800
commit85360acc4d93e135a647bf4819b9ba524df3cdf0 (patch)
tree4fcc91cdd8d916b619c85c5c442958040d0ccdfa /meta-oe/recipes-graphics
parent51648324086a34abe212c659ce3e6b70edd0e210 (diff)
downloadmeta-openembedded-85360acc4d93e135a647bf4819b9ba524df3cdf0.tar.gz
jasper: Fix install conflict when enable multilib.
Error: Transaction test error: file /usr/include/jasper/jas_config.h conflicts between attempted installs of lib32-jasper-dev-4.1.1-r0.armv7ahf_neon and jasper-dev-4.1.1-r0.cortexa57 The differences between the two files are as follows: @@ -44,10 +44,10 @@ /* #undef JAS_HAVE_INT128_T */ #define JAS_SIZEOF_INT 4 -#define JAS_SIZEOF_LONG 4 +#define JAS_SIZEOF_LONG 8 #define JAS_SIZEOF_LLONG 8 -#define JAS_SIZEOF_SIZE_T 4 -#define JAS_SIZEOF_SSIZE_T 4 +#define JAS_SIZEOF_SIZE_T 8 +#define JAS_SIZEOF_SSIZE_T 8 #define JAS_HAVE_FCNTL_H /* #undef JAS_HAVE_IO_H */ Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/jasper/jasper_4.1.1.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/jasper/jasper_4.1.1.bb b/meta-oe/recipes-graphics/jasper/jasper_4.1.1.bb
index 14f50d0b29..5281980ecb 100644
--- a/meta-oe/recipes-graphics/jasper/jasper_4.1.1.bb
+++ b/meta-oe/recipes-graphics/jasper/jasper_4.1.1.bb
@@ -10,7 +10,7 @@ CVE_STATUS[CVE-2015-8751] = "fixed-version: The CPE in the NVD database doesn't
S = "${WORKDIR}/git"
-inherit cmake
+inherit cmake multilib_header
do_configure:prepend() {
JAS_STDC_VERSION="$(echo __STDC_VERSION__ | ${CPP} -E -P -)"
@@ -29,5 +29,6 @@ do_install:append() {
chrpath -d ${D}${bindir}/imginfo
chrpath -d ${D}${bindir}/imgcmp
chrpath -d ${D}${libdir}/libjasper.so.*
+ oe_multilib_header jasper/jas_config.h
}