aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorMarkus Volk <f_l_k@t-online.de>2024-03-10 11:38:39 +0100
committerKhem Raj <raj.khem@gmail.com>2024-03-10 21:54:07 -0700
commit3e6f301fb5bef55d42434f97c349fe7c2bdd2b54 (patch)
treea8805bbc8a02017a36987b5d3f52bcfec51ebc93 /meta-oe/recipes-graphics
parent2669bca479050490b8e00e2e7c768f378089610a (diff)
downloadmeta-openembedded-3e6f301fb5bef55d42434f97c349fe7c2bdd2b54.tar.gz
waylandpp: fix reproducibility issue
remove STAGING_DIR_HOST and S from the waylandpp-targets.cmake file Signed-off-by: Markus Volk <f_l_k@t-online.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb b/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
index eb8ec4f5ff..c1f5f4ed8e 100644
--- a/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
+++ b/meta-oe/recipes-graphics/wayland/waylandpp_1.0.0.bb
@@ -37,4 +37,9 @@ EXTRA_OECMAKE:class-target = " \
-DCMAKE_EXE_LINKER_FLAGS="-Wl,--enable-new-dtags" \
"
+do_install:append:class-target() {
+ sed -i -e 's|${S}||g' ${D}${libdir}/cmake/waylandpp/waylandpp-targets.cmake
+ sed -i -e 's|${STAGING_DIR_HOST}||g' ${D}${libdir}/cmake/waylandpp/waylandpp-targets.cmake
+}
+
BBCLASSEXTEND += "native nativesdk"