aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorMarek Vasut <marex@denx.de>2024-03-13 05:40:10 +0100
committerKhem Raj <raj.khem@gmail.com>2024-03-12 22:28:39 -0700
commit2054fda6d1dea9a0310f817492dfd743357372ad (patch)
tree43058f0c12cebb598fda466e8e6add63949558d4 /meta-oe/recipes-graphics
parent87e19a8c3d62fe8b5a824f09173966ffb8fcd3a6 (diff)
downloadmeta-openembedded-2054fda6d1dea9a0310f817492dfd743357372ad.tar.gz
lvgl: Build shared library
Build LVGL as shared library instead of static library. In case there are multiple applications linking against LVGL, this is more efficient, and it also makes it possible to update only the LVGL library separately from the applications. Signed-off-by: Marek Vasut <marex@denx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb b/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
index bdd61d891f..d147e89203 100644
--- a/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lvgl_9.0.0.bb
@@ -14,7 +14,7 @@ PV .= "+git${SRCPV}"
inherit cmake
-EXTRA_OECMAKE = "-DLIB_INSTALL_DIR=${baselib}"
+EXTRA_OECMAKE = "-DLIB_INSTALL_DIR=${baselib} -DBUILD_SHARED_LIBS=ON"
S = "${WORKDIR}/git"
ALLOW_EMPTY:${PN} = "1"