aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/freeglut
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-09-20 10:41:08 +0200
committerKhem Raj <raj.khem@gmail.com>2023-09-20 22:15:39 -0700
commitf721876add48dccfd228cc09ef261909afeb2d25 (patch)
tree30826de7522f8644f11536cf4a40e1efada7390f /meta-oe/recipes-graphics/freeglut
parentd6d82297ac08603fa26f76fde3c032a3957c5a45 (diff)
downloadmeta-openembedded-f721876add48dccfd228cc09ef261909afeb2d25.tar.gz
freeglut: return x11 to REQUIRED_DISTRO_FEATURES
* depends on libxi causing: ERROR: Nothing PROVIDES 'libxi' (but /OE/build/luneos-nanbield/meta-openembedded/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb DEPENDS on or otherwise requires it) libxi was skipped: missing required distro feature 'x11' (not in DISTRO_FEATURES) ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'freeglut', 'libxi'] for distros with opengl but without x11 in DISTRO_FEATURES Signed-off-by: Martin Jansa <martin.jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/freeglut')
-rw-r--r--meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb b/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
index b433900bb0..2cd00b0349 100644
--- a/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
+++ b/meta-oe/recipes-graphics/freeglut/freeglut_3.4.0.bb
@@ -8,8 +8,8 @@ SRC_URI[sha256sum] = "3c0bcb915d9b180a97edaebd011b7a1de54583a838644dcd42bb0ea0c6
inherit cmake features_check pkgconfig
-# depends on virtual/libgl
-REQUIRED_DISTRO_FEATURES = "opengl"
+# depends on virtual/libgl and libxi
+REQUIRED_DISTRO_FEATURES = "opengl x11"
PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'wayland x11', d)}"
PACKAGECONFIG[gles] = "-DFREEGLUT_GLES=ON,-DFREEGLUT_GLES=OFF,"