aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/pam
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-12-23 14:54:24 -0800
committerKhem Raj <raj.khem@gmail.com>2019-12-23 15:03:15 -0800
commit9641947fa0e36e1341a931bc3f9c5e894065a594 (patch)
treeb173af6e53494799ade3f3e693bb1c75cd48dcc8 /meta-oe/recipes-extended/pam
parent7197d3ed7310bbbf1628af10dc2fce3a5853d73b (diff)
downloadmeta-openembedded-9641947fa0e36e1341a931bc3f9c5e894065a594.tar.gz
pam-plugin-ldapdb: Include <stdexcept> for std::invalid_argument
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/pam')
-rw-r--r--meta-oe/recipes-extended/pam/pam-plugin-ldapdb/0001-include-stdexcept-for-std-invalid_argument.patch25
-rw-r--r--meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb4
2 files changed, 28 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/pam/pam-plugin-ldapdb/0001-include-stdexcept-for-std-invalid_argument.patch b/meta-oe/recipes-extended/pam/pam-plugin-ldapdb/0001-include-stdexcept-for-std-invalid_argument.patch
new file mode 100644
index 0000000000..0a93411533
--- /dev/null
+++ b/meta-oe/recipes-extended/pam/pam-plugin-ldapdb/0001-include-stdexcept-for-std-invalid_argument.patch
@@ -0,0 +1,25 @@
+From 3e97c9004f4ec58ca3696ee6298f91e6eeb76e04 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Mon, 23 Dec 2019 14:46:25 -0800
+Subject: [PATCH] include <stdexcept> for std::invalid_argument
+
+Upstream-Status: Submitted [https://github.com/rmbreak/pam_ldapdb/pull/11]
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ pam_ldapdb.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/pam_ldapdb.cpp b/pam_ldapdb.cpp
+index 9baf1e6..be5d85c 100644
+--- a/pam_ldapdb.cpp
++++ b/pam_ldapdb.cpp
+@@ -1,5 +1,6 @@
+ #include <map>
+ #include <string>
++#include <stdexcept>
+ #include <utility>
+ #include <syslog.h>
+ #include <pwd.h>
+--
+2.24.1
+
diff --git a/meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb b/meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb
index 6864cc3174..626b22fe48 100644
--- a/meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb
+++ b/meta-oe/recipes-extended/pam/pam-plugin-ldapdb_1.3.bb
@@ -11,7 +11,9 @@ inherit features_check
REQUIRED_DISTRO_FEATURES = "pam"
SRCREV = "84d7b260f1ae6857ae36e014c9a5968e8aa1cbe8"
-SRC_URI = "git://github.com/rmbreak/pam_ldapdb"
+SRC_URI = "git://github.com/rmbreak/pam_ldapdb \
+ file://0001-include-stdexcept-for-std-invalid_argument.patch \
+"
S = "${WORKDIR}/git"