aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/iotop
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-01-19 16:33:15 -0800
committerKhem Raj <raj.khem@gmail.com>2020-01-22 09:56:34 -0800
commit505774658338002a92c2e32c4c57c55f36c5e36e (patch)
treec5d1032aac37af7493141cdfa56da5b371ce5a59 /meta-oe/recipes-extended/iotop
parent66454b26ff49c6cca3dd8d32832078cfa05cd5ef (diff)
downloadmeta-openembedded-505774658338002a92c2e32c4c57c55f36c5e36e.tar.gz
meta-oe: Remove using python2
This change makes the parsing go though, we still might have build issues, which will be reported in world builds seprately Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/iotop')
-rw-r--r--meta-oe/recipes-extended/iotop/iotop_0.6.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-extended/iotop/iotop_0.6.bb b/meta-oe/recipes-extended/iotop/iotop_0.6.bb
index b01d7f64e6..68cc352249 100644
--- a/meta-oe/recipes-extended/iotop/iotop_0.6.bb
+++ b/meta-oe/recipes-extended/iotop/iotop_0.6.bb
@@ -15,13 +15,13 @@ SRC_URI[sha256sum] = "3adea2a24eda49bbbaeb4e6ed2042355b441dbd7161e883067a02bfc8d
UPSTREAM_CHECK_URI = "http://repo.or.cz/iotop.git/tags"
UPSTREAM_CHECK_REGEX = "iotop-(?P<pver>\d+(\.\d+)+)"
-inherit distutils
+inherit distutils3
do_install_append() {
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.pyo || true
rm -f ${D}${PYTHON_SITEPACKAGES_DIR}/site.py || true
}
-RDEPENDS_${PN} = "python-curses python-textutils \
- python-codecs python-ctypes python-pprint \
- python-shell python-subprocess python-core"
+RDEPENDS_${PN} = "python3-curses python3-textutils \
+ python3-codecs python3-ctypes python3-pprint \
+ python3-shell python3-subprocess python3-core"