aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-01-23 09:20:04 +0800
committerKhem Raj <raj.khem@gmail.com>2024-01-23 11:55:34 -0800
commitb35224e1914953c510da169152ebf368049c762b (patch)
tree9ec4e36aa1f52044d801c8f1d847e4c5c4f245a6 /meta-oe/recipes-devtools
parent3fd4d0e8533fbece06b0d72e48aea854359f0068 (diff)
downloadmeta-openembedded-b35224e1914953c510da169152ebf368049c762b.tar.gz
python3-apscheduler: add new recipe
Add a new recipe for python3-apscheduler, a task scheduler and task queue system for Python. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python3-apscheduler_3.10.4.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python3-apscheduler_3.10.4.bb b/meta-oe/recipes-devtools/python/python3-apscheduler_3.10.4.bb
new file mode 100644
index 0000000000..01ffa25ac6
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python3-apscheduler_3.10.4.bb
@@ -0,0 +1,13 @@
+SUMMARY = "Advanced Python Scheduler (APScheduler) is a Python library that lets you schedule your Python code to be executed later, either just once or periodically."
+HOMEPAGE = "https://github.com/agronholm/apscheduler"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f0e423eea5c91e7aa21bdb70184b3e53"
+
+SRC_URI[sha256sum] = "e6df071b27d9be898e486bc7940a7be50b4af2e9da7c08f0744a96d4bd4cef4a"
+
+PYPI_PACKAGE = "APScheduler"
+
+inherit pypi python_setuptools_build_meta
+
+DEPENDS += "python3-setuptools-scm-native"