aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/mercurial
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-devtools/mercurial
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/mercurial')
-rw-r--r--meta-oe/recipes-devtools/mercurial/mercurial_5.5.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/mercurial/mercurial_5.5.bb b/meta-oe/recipes-devtools/mercurial/mercurial_5.5.bb
index 7980960f1f..ae978aea93 100644
--- a/meta-oe/recipes-devtools/mercurial/mercurial_5.5.bb
+++ b/meta-oe/recipes-devtools/mercurial/mercurial_5.5.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
DEPENDS = "python3 python3-native"
-RDEPENDS_${PN} = "python3 python3-modules"
+RDEPENDS:${PN} = "python3 python3-modules"
inherit python3native
@@ -22,7 +22,7 @@ export LDSHARED="${CCLD} -shared"
EXTRA_OEMAKE = "STAGING_LIBDIR=${STAGING_LIBDIR} STAGING_INCDIR=${STAGING_INCDIR} \
PREFIX=${prefix}"
-do_configure_append () {
+do_configure:append () {
sed -i -e 's:PYTHON?=python:PYTHON=python3:g' ${S}/Makefile
}
@@ -32,7 +32,7 @@ do_install () {
}
PACKAGES =+ "${PN}-python"
-FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}"
+FILES:${PN} += "${PYTHON_SITEPACKAGES_DIR}"
-FILES_${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"
+FILES:${PN}-python = "${nonarch_libdir}/${PYTHON_DIR}"