aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-02-23 15:52:46 +0800
committerKhem Raj <raj.khem@gmail.com>2022-02-24 08:35:24 -0800
commit1cae7dc06e398a605d402a70c2533bfbd0ad058c (patch)
tree35e0e63d30a122aae39f2e343e150f0fd799c6c7 /meta-oe/recipes-dbs
parent6f2008ee408d89fdcea22a63e72cd40ff02db3e3 (diff)
downloadmeta-openembedded-1cae7dc06e398a605d402a70c2533bfbd0ad058c.tar.gz
soci: upgrade 4.0.2 -> 4.0.3
0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch removed since it's included in 4.0.3 Version 4.0.3 differs from 4.0.2 in the following ways: ======================================================== Changes affecting all or multiple backends: - Fix opening sessions from pool (#891). - Fix default backend search path (#928). - Fix build with latest glibc versions where SIGSTKSZ is not constant (#886). - Document using SOCI as a CMake subdirectory (#925). - Document using SOCI with Conan (#877). Backend-specific changes: - MySQL - Implement get_table_names() for MySQL (#927). - Fix MySQL backend build with MySQL >= 8 (#884). - Fix mysql_library_end() in multithreaded environment (#909). - Make mysql_soci_error::get_error_category() more useful (#902). - ODBC - Fix several bugs in vector into code (#888, #892). - Fix memory leaks in case of SQLNumResultCols() failure. - Export odbc_session_backend::get_database_product() from DLL. - Oracle - Add support for detecting Oracle 20 and 21 to CMake (#896). - PostgreSQL - Fix compilation when "free" is redefined somewhere else. - SQLite3 - Fix bulk operations with vectors of size 1 in SQLite3 backend (#908). - Firebird - Suppress FB memory leaks Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-dbs')
-rw-r--r--meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch42
-rw-r--r--meta-oe/recipes-dbs/soci/soci_4.0.3.bb (renamed from meta-oe/recipes-dbs/soci/soci_4.0.2.bb)5
2 files changed, 2 insertions, 45 deletions
diff --git a/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch b/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch
deleted file mode 100644
index 8e32ebb0bf..0000000000
--- a/meta-oe/recipes-dbs/soci/soci/0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From fae154eb209e068586e1adb589de5d273fcf4b4f Mon Sep 17 00:00:00 2001
-From: Denis Arnaud <denis.arnaud_fedora@m4x.org>
-Date: Tue, 18 May 2021 00:05:03 +0200
-Subject: [PATCH] Fix build when SIGSTKSZ is no longer a constant
-
-In the latest glibc versions SIGSTKSZ is not a constant any more, which
-broke building the tests with it.
-
-Work around this by hard-coding a typical value for it.
-
-closes #886.
-
-Upstream-Status: Backport.
----
- tests/catch.hpp | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/catch.hpp b/tests/catch.hpp
-index 014df2c5..85067813 100644
---- a/tests/catch.hpp
-+++ b/tests/catch.hpp
-@@ -6489,7 +6489,7 @@ namespace Catch {
- static bool isSet;
- static struct sigaction oldSigActions [sizeof(signalDefs)/sizeof(SignalDefs)];
- static stack_t oldSigStack;
-- static char altStackMem[SIGSTKSZ];
-+ static char altStackMem[8192];
-
- static void handleSignal( int sig ) {
- std::string name = "<unknown signal>";
-@@ -6540,7 +6540,7 @@ namespace Catch {
- bool FatalConditionHandler::isSet = false;
- struct sigaction FatalConditionHandler::oldSigActions[sizeof(signalDefs)/sizeof(SignalDefs)] = {};
- stack_t FatalConditionHandler::oldSigStack = {};
-- char FatalConditionHandler::altStackMem[SIGSTKSZ] = {};
-+ char FatalConditionHandler::altStackMem[8192] = {};
-
- } // namespace Catch
-
---
-2.25.1
-
diff --git a/meta-oe/recipes-dbs/soci/soci_4.0.2.bb b/meta-oe/recipes-dbs/soci/soci_4.0.3.bb
index fb67e0c547..ff47e5033e 100644
--- a/meta-oe/recipes-dbs/soci/soci_4.0.2.bb
+++ b/meta-oe/recipes-dbs/soci/soci_4.0.3.bb
@@ -5,9 +5,8 @@ LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
SECTION = "libs"
DEPENDS = "boost"
-SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz \
- file://0001-Fix-build-when-SIGSTKSZ-is-no-longer-a-constant.patch"
-SRC_URI[sha256sum] = "34da2d2320539463da8a5131253246fa2671e0438ab5fd1e5119edb428f558a5"
+SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${BP}/${BP}.tar.gz"
+SRC_URI[sha256sum] = "615e5f7e4b52007f3a3b4050a99aadf6346b56b5098eb08b3a650836083c6a33"
TESTCONFIG = '-DSOCI_TEST_EMPTY_CONNSTR="dummy" -DSOCI_TEST_SQLITE3_CONNSTR="test.db" \
-DSOCI_TEST_POSTGRESQL_CONNSTR:STRING="dbname=soci_test" \