aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2022-02-01 16:52:48 +0000
committerKhem Raj <raj.khem@gmail.com>2022-02-03 08:44:32 -0800
commit880defa7297f2e3594092878b4f43cf7a487d849 (patch)
tree4afbfd41c20b29394ee0398bbb6d28447b97ce9c /meta-oe/recipes-bsp
parentff9442e0f921758524a63411664813c98402688c (diff)
downloadmeta-openembedded-880defa7297f2e3594092878b4f43cf7a487d849.tar.gz
fwupd-efi: upgrade to 1.2
Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/fwupd/fwupd-efi/cc.patch10
-rw-r--r--meta-oe/recipes-bsp/fwupd/fwupd-efi_1.2.bb (renamed from meta-oe/recipes-bsp/fwupd/fwupd-efi_1.1.bb)3
2 files changed, 6 insertions, 7 deletions
diff --git a/meta-oe/recipes-bsp/fwupd/fwupd-efi/cc.patch b/meta-oe/recipes-bsp/fwupd/fwupd-efi/cc.patch
index ac345f2752..6fd2eca941 100644
--- a/meta-oe/recipes-bsp/fwupd/fwupd-efi/cc.patch
+++ b/meta-oe/recipes-bsp/fwupd/fwupd-efi/cc.patch
@@ -20,7 +20,7 @@ index e42b365..4831a48 100755
import sys
import argparse
@@ -19,7 +20,7 @@ def _generate_sbat(args):
- FWUPD_URL = "https://github.com/fwupd/fwupd"
+ FWUPD_URL = "https://github.com/fwupd/fwupd-efi"
subprocess.run(
- [args.cc, "-x", "c", "-c", "-o", args.outfile, "/dev/null"], check=True
@@ -32,13 +32,13 @@ diff --git a/efi/meson.build b/efi/meson.build
index 68ea4aa..dcf0d43 100644
--- a/efi/meson.build
+++ b/efi/meson.build
-@@ -184,7 +184,7 @@ o_file5 = custom_target('fwup-sbat.o',
+@@ -187,7 +187,7 @@ o_file5 = custom_target('fwup-sbat.o',
command : [
- join_paths(meson.current_source_dir(), 'generate_sbat.py'),
+ generate_sbat,
'@OUTPUT@',
- '--cc', efi_cc,
+ '--cc', ' '.join(efi_cc),
- '--objcopy', efi_objcopy,
+ '--objcopy', objcopy,
'--project-name', meson.project_name(),
'--project-version', meson.project_version(),
diff --git a/meson_options.txt b/meson_options.txt
@@ -49,5 +49,5 @@ index d869cd2..17ef7fb 100644
-option('efi-cc', type : 'string', value : 'gcc', description : 'the compiler to use for EFI modules')
+option('efi-cc', type : 'array', value : ['gcc'], description : 'the compiler to use for EFI modules')
option('efi-ld', type : 'string', value : 'ld', description : 'the linker to use for EFI modules')
- option('efi-objcopy', type : 'string', value : 'objcopy', description : 'the objcopy utility to use for EFI modules')
option('efi-libdir', type : 'string', description : 'path to the EFI lib directory')
+ option('efi-ldsdir', type : 'string', description : 'path to the EFI lds directory')
diff --git a/meta-oe/recipes-bsp/fwupd/fwupd-efi_1.1.bb b/meta-oe/recipes-bsp/fwupd/fwupd-efi_1.2.bb
index 2165b42293..b88db2e53c 100644
--- a/meta-oe/recipes-bsp/fwupd/fwupd-efi_1.1.bb
+++ b/meta-oe/recipes-bsp/fwupd/fwupd-efi_1.2.bb
@@ -4,7 +4,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
SRC_URI = "git://github.com/fwupd/fwupd-efi;protocol=https;branch=main \
file://cc.patch"
-SRCREV = "fee1b8f6473cb403b8ae7a56961ba0557e3f3efa"
+SRCREV = "8de5918507dcc797e612aac688d6b60b90053f54"
S = "${WORKDIR}/git"
DEPENDS = "gnu-efi"
@@ -20,7 +20,6 @@ SBAT_DISTRO_URL ?= ""
EXTRA_OEMESON += "-Defi-cc="${@meson_array('CC', d)}" \
-Defi-ld='${HOST_PREFIX}ld' \
- -Defi-objcopy='${OBJCOPY}' \
-Defi-includedir=${STAGING_INCDIR}/efi \
-Defi-libdir=${STAGING_LIBDIR} \
-Defi_sbat_distro_id='${SBAT_DISTRO_ID}' \