aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorRichard Hughes <hughsient@gmail.com>2022-03-07 15:02:19 +0000
committerKhem Raj <raj.khem@gmail.com>2022-03-07 09:27:53 -0800
commit5c5a21112d19d047a36fbfd3cdfbb3ee5528fd99 (patch)
tree1d8d9e62518857b166d3d0b1dec7dc1ae6a7375e /meta-oe/recipes-bsp
parent5f11eefb8d72e41645e7ce9971440d3246aace65 (diff)
downloadmeta-openembedded-5c5a21112d19d047a36fbfd3cdfbb3ee5528fd99.tar.gz
fwupd: New release
New features: - Add a flag to indicate the device has a signed or unsigned payload - Add a plugin to set a GPIO pin for the duration of an update - Add a simple plugin to enumerate (but not update) SCSI hardware - Add two more instance IDs to the MTD devices - Add X-BaseboardManagementController as an update category - Allow assigning issues to devices for known high priority problems - Parse the MTD firmware version using the defined GType Fixed bugs: - Modify the AT retry behavior to fix getting the firmware branch - Do not show a warning if the TPM eventlog does not exist - Do not show TSS2 warning messages by default - Fix a critical warning when loading an empty TPM eventlog item - Fix the error handling when updating USB4 retimers - Show the user when devices are not updatable due to inhibits - Skip probing the Dell DA300 device to avoid a warning - Try harder to convert to a version into a correct semver - Use multiple checksums when there are no provided artifacts Signed-off-by: Richard Hughes <richard@hughsie.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/fwupd/fwupd_1.7.6.bb (renamed from meta-oe/recipes-bsp/fwupd/fwupd_1.7.3.bb)8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta-oe/recipes-bsp/fwupd/fwupd_1.7.3.bb b/meta-oe/recipes-bsp/fwupd/fwupd_1.7.6.bb
index 93c0e741e8..53f1720b04 100644
--- a/meta-oe/recipes-bsp/fwupd/fwupd_1.7.3.bb
+++ b/meta-oe/recipes-bsp/fwupd/fwupd_1.7.6.bb
@@ -6,7 +6,7 @@ DEPENDS = "glib-2.0 libxmlb json-glib sqlite3 libjcat gcab vala-native"
SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.xz \
file://run-ptest"
-SRC_URI[sha256sum] = "109dacc16ed0db71eb08b852e96b070b8c2c53516a3071b9d0683acd8ecd42d9"
+SRC_URI[sha256sum] = "7ebe1514acb688d2649cecc392db929094da3f03cfc98a9c0faccabb084912fa"
UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
@@ -32,6 +32,7 @@ PACKAGECONFIG ??= "curl gnutls gudev gusb \
plugin_ep963x \
plugin_fastboot \
plugin_flashrom \
+ plugin_gpio \
plugin_intel_spi \
plugin_logitech_bulkcontroller \
plugin_modem_manager \
@@ -45,7 +46,9 @@ PACKAGECONFIG ??= "curl gnutls gudev gusb \
plugin_redfish \
plugin_synaptics_mst \
plugin_synaptics_rmi \
+ plugin_scsi \
plugin_thunderbolt \
+ plugin_uf2 \
plugin_upower \
sqlite"
@@ -80,6 +83,7 @@ PACKAGECONFIG[plugin_emmc] = "-Dplugin_emmc=true,-Dplugin_emmc=false"
PACKAGECONFIG[plugin_ep963x] = "-Dplugin_ep963x=true,-Dplugin_ep963x=false"
PACKAGECONFIG[plugin_fastboot] = "-Dplugin_fastboot=true,-Dplugin_fastboot=false"
PACKAGECONFIG[plugin_flashrom] = "-Dplugin_flashrom=true,-Dplugin_flashrom=false,flashrom"
+PACKAGECONFIG[plugin_gpio] = "-Dplugin_gpio=true,-Dplugin_gpio"
PACKAGECONFIG[plugin_intel_spi] = "-Dplugin_intel_spi=true -Dlzma=true,-Dplugin_intel_spi=false -Dlzma=false,xz"
PACKAGECONFIG[plugin_logitech_bulkcontroller] = "-Dplugin_logitech_bulkcontroller=true,-Dplugin_logitech_bulkcontroller=false,protobuf-c-native protobuf-c"
PACKAGECONFIG[plugin_modem_manager] = "-Dplugin_modem_manager=true,-Dplugin_modem_manager=false,libqmi modemmanager"
@@ -92,6 +96,7 @@ PACKAGECONFIG[plugin_platform_integrity] = "-Dplugin_platform_integrity=true,-Dp
PACKAGECONFIG[plugin_powerd] = "-Dplugin_powerd=true,-Dplugin_powerd=false"
PACKAGECONFIG[plugin_realtek_mst] = "-Dplugin_realtek_mst=true,-Dplugin_realtek_mst=false"
PACKAGECONFIG[plugin_redfish] = "-Dplugin_redfish=true,-Dplugin_redfish=false"
+PACKAGECONFIG[plugin_scsi] = "-Dplugin_scsi=true,-Dplugin_scsi=false"
PACKAGECONFIG[plugin_synaptics_mst] = "-Dplugin_synaptics_mst=true,-Dplugin_synaptics_mst=false"
PACKAGECONFIG[plugin_synaptics_rmi] = "-Dplugin_synaptics_rmi=true,-Dplugin_synaptics_rmi=false"
PACKAGECONFIG[plugin_thunderbolt] = "-Dplugin_thunderbolt=true,-Dplugin_thunderbolt=false"
@@ -99,6 +104,7 @@ PACKAGECONFIG[plugin_tpm] = "-Dplugin_tpm=true,-Dplugin_tpm=false,tpm2-tss"
# Turn off the capsule splash as it needs G-I at buildtime, which isn't currently supported
PACKAGECONFIG[plugin_uefi_capsule] = "-Dplugin_uefi_capsule=true -Dplugin_uefi_capsule_splash=false,-Dplugin_uefi_capsule=false,efivar fwupd-efi"
PACKAGECONFIG[plugin_uefi_pk] = "-Dplugin_uefi_pk=true,-Dplugin_uefi_pk=false"
+PACKAGECONFIG[plugin_uf2] = "-Dplugin_uf2=true,-Dplugin_uf2=false"
PACKAGECONFIG[plugin_upower] = "-Dplugin_upower=true,-Dplugin_upower=false"
# Always disable these plugins on non-x86 platforms as they don't compile or are useless