aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-bsp
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-08-04 17:37:21 -0700
committerKhem Raj <raj.khem@gmail.com>2023-08-05 09:29:56 -0700
commit3b2f72f31a5e4856d7c7cdda18a0f72eb68309bf (patch)
treeace9960dec38dc3d952cb330829641a9052d59ee /meta-oe/recipes-bsp
parentd572afcd08f3bedc4cf6fc9ac6e52e4f0797ccd0 (diff)
downloadmeta-openembedded-3b2f72f31a5e4856d7c7cdda18a0f72eb68309bf.tar.gz
pcmciautils: Pass LD=CC via Make cmdline
This ensures that LD is always consistent in Makefile and it is computed independent of LD variable setting order in metadata e.g. when using meta-clang with lld the LD var maybe set to ld.ldd and this will be wrong here Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-bsp')
-rw-r--r--meta-oe/recipes-bsp/pcmciautils/pcmciautils_018.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-oe/recipes-bsp/pcmciautils/pcmciautils_018.bb b/meta-oe/recipes-bsp/pcmciautils/pcmciautils_018.bb
index 42dfcd1e5b..52e9b136c8 100644
--- a/meta-oe/recipes-bsp/pcmciautils/pcmciautils_018.bb
+++ b/meta-oe/recipes-bsp/pcmciautils/pcmciautils_018.bb
@@ -28,11 +28,10 @@ export pcmciaconfdir = "${sysconfdir}/pcmcia"
export udevdir = "`pkg-config --variable=udevdir udev`"
export udevrulesdir = "`pkg-config --variable=udevdir udev`/rules.d"
export UDEV = "1"
-LD = "${CC}"
CFLAGS =+ "-I${S}/src"
CFLAGS =+ "-DPCMCIAUTILS_VERSION=\\"${PV}\\""
-EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs' 'LEX=flex'"
+EXTRA_OEMAKE = "-e 'STRIP=echo' 'LIB_OBJS=-lc -lsysfs' 'LEX=flex' 'LD=${CC}'"
do_install () {
oe_runmake 'DESTDIR=${D}' install