aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-22 18:25:58 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-23 08:48:18 -0700
commitb1b7ee87ac55fced4bcf88b0e374025d7f908731 (patch)
tree8a2febeb3a9e5dc2509d5f4d1ef44860af7db2c1 /meta-networking
parentda331ae8f1fccf3b542526f1caaa3834261434fa (diff)
downloadmeta-openembedded-b1b7ee87ac55fced4bcf88b0e374025d7f908731.tar.gz
system-config-printer: Delete __pycache__ files
These pyc files include references to buildtime TMPDIR, therefore delete them and let them be regerated during runtime if needed. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb b/meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb
index 883d582371..f0ff24f376 100644
--- a/meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb
+++ b/meta-networking/dynamic-layers/meta-python/recipes-printing/system-config-printer/system-config-printer_1.5.18.bb
@@ -21,6 +21,15 @@ do_configure:prepend() {
touch ${S}/ChangeLog
}
+do_install:append() {
+ for f in __init__.cpython-311.pyc cupshelpers.cpython-311.pyc \
+ config.cpython-311.pyc ppds.cpython-311.pyc \
+ installdriver.cpython-311.pyc openprinting.cpython-311.pyc \
+ xmldriverprefs.cpython-311.pyc; do
+ rm -rf ${D}${PYTHON_SITEPACKAGES_DIR}/cupshelpers/__pycache__/$f
+ done
+}
+
FILES:${PN} += "${libdir} ${datadir}"
RDEPENDS:${PN} = " \