aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-14 15:25:05 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-14 15:28:06 -0700
commit35bef1eae0a28ae605a32b6c41633cf9dfc76c21 (patch)
tree55c493dd2c99328038fdd086a69bb57a804a9672 /meta-networking
parent9af3510170137070cb269e6cf0399ac43ad8bece (diff)
downloadmeta-openembedded-35bef1eae0a28ae605a32b6c41633cf9dfc76c21.tar.gz
squid: Remove buildpaths from generated binaries
Compiler invocation and flags are added to SQUID_CONFIGURE_OPTIONS which is added via generated autoconf.h during configure step. Since OE encodes sysroot and buildpaths for cross compile, they end up in squid binary, this patch removes from workdir from them so avoid encoding build workspace path Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-daemons/squid/squid_5.7.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/squid/squid_5.7.bb b/meta-networking/recipes-daemons/squid/squid_5.7.bb
index a208a2a88f..2a5de1872d 100644
--- a/meta-networking/recipes-daemons/squid/squid_5.7.bb
+++ b/meta-networking/recipes-daemons/squid/squid_5.7.bb
@@ -69,6 +69,10 @@ do_configure:prepend() {
export SYSROOT=$PKG_CONFIG_SYSROOT_DIR
}
+do_configure:append() {
+ sed -i -e 's|${WORKDIR}||g' ${B}/include/autoconf.h
+}
+
do_compile_ptest() {
oe_runmake -C ${TESTDIR} buildtest-TESTS
}