aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-25 21:54:43 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-26 08:28:37 -0700
commit26842ecc3b4811fd39a65c55af0711777f41fdbb (patch)
treeb1a1aa47fe8136ded3e71bcd7ff981de70d111ff /meta-networking
parent1b0f5d30688839025b0b696fee7dee6b55e05dab (diff)
downloadmeta-openembedded-26842ecc3b4811fd39a65c55af0711777f41fdbb.tar.gz
vlan: Pass CFLAGS via CCFLAGS
CCFLAGS is used in Make rules which will ensure file remapping options are used when compiling Fixes WARNING: vlan-1.9-r0 do_package_qa: QA Issue: File /usr/sbin/.debug/vconfig.vlan in package vlan-dbg contains reference to TMPDIR [buildpaths] Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking')
-rw-r--r--meta-networking/recipes-connectivity/vlan/vlan_1.9.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
index 035d4946f1..b478692e39 100644
--- a/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
+++ b/meta-networking/recipes-connectivity/vlan/vlan_1.9.bb
@@ -28,7 +28,7 @@ do_configure:append () {
# ignore strip to avoid yocto errors in stripping
do_compile () {
- oe_runmake PLATFORM=ARM 'STRIP=echo' all
+ oe_runmake PLATFORM=ARM 'STRIP=echo' CCFLAGS="${CFLAGS}" all
}
do_install () {