aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.2.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-03-19 13:45:02 +0800
committerKhem Raj <raj.khem@gmail.com>2024-03-20 09:28:06 -0700
commit0bfe8ae43295cb51ec394060396a915e80bbfda5 (patch)
tree6d6871367db0e927d76abe57933d6e434264600e /meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.2.4.bb
parent7c92b0074589dc0accc8f8073592e54027897e58 (diff)
downloadmeta-openembedded-0bfe8ae43295cb51ec394060396a915e80bbfda5.tar.gz
networkd-dispatcher: upgrade 2.1 -> 2.2.4
Changelog: ========== - Improve performance when getting interface status - update project URL - Add environment variables to manpage. - Don't start the daemon if there's nothing to do - _interface_scan: fix wrong index into iface map - _interface_scan: force handle_state for new interfaces - Add missing administrative state 'initialized' - use os.path.dirname instead of os.path.basename - make sure scripts are not writeable by non-root users - don't allow unknown operational/admin states (CVE-2022-29799, CVE-2022-29800) - Fix missing word in exception message - fix some new linting issues from pylint - manpage: fix missing slash in "configured.d" directory name - Normalize parsed IP address value - Drop support for Python 3.4 - Add testing for Python 3.10 - README.md: fix code formatting Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.2.4.bb')
-rw-r--r--meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.2.4.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.2.4.bb b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.2.4.bb
new file mode 100644
index 0000000000..f0f7eb5df6
--- /dev/null
+++ b/meta-networking/recipes-daemons/networkd-dispatcher/networkd-dispatcher_2.2.4.bb
@@ -0,0 +1,31 @@
+SUMMARY = "Dispatcher service for systemd-networkd connection status changes"
+DESCRIPTION = "This daemon is similar to NetworkManager-dispatcher, but is much \
+more limited in the types of events it supports due to the limited nature of \
+systemd-networkd(8)."
+
+LICENSE = "GPL-3.0-only"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
+
+inherit features_check systemd
+
+RDEPENDS:${PN} = "python3-pygobject python3-dbus"
+REQUIRED_DISTRO_FEATURES = "systemd gobject-introspection-data"
+
+SRCREV = "dfd26d72793914eb3da910ef8c71de6d7c8942a2"
+SRC_URI = "git://gitlab.com/craftyguy/networkd-dispatcher;protocol=https;nobranch=1"
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_PACKAGES = "${PN}"
+SYSTEMD_SERVICE:${PN} = "networkd-dispatcher.service"
+SYSTEMD_AUTO_ENABLE = "disable"
+
+# Nothing to build, just a python script to install
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install() {
+ install -D -m 0755 ${S}/networkd-dispatcher ${D}${bindir}/networkd-dispatcher
+ install -D -m 0644 ${S}/networkd-dispatcher.service ${D}/${systemd_system_unitdir}/networkd-dispatcher.service
+ install -D -m 0644 ${S}/networkd-dispatcher.conf ${D}/${sysconfdir}/conf.d/networkd-dispatcher.conf
+}