aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gdm
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-09 20:31:31 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-09 20:31:31 +0200
commit9d16b96d3d813f372c2383f5cb25fda6b6095ec7 (patch)
treef0842a6a21227be50052b469da61b3e702c88085 /meta-gnome/recipes-gnome/gdm
parent5edc0def9d0668f0f540f451c71b89270ebc58f6 (diff)
downloadmeta-openembedded-9d16b96d3d813f372c2383f5cb25fda6b6095ec7.tar.gz
gdm 2.32.2: add systemd support
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-gnome/recipes-gnome/gdm')
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm/gdm.service11
-rw-r--r--meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb28
2 files changed, 39 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gdm/gdm/gdm.service b/meta-gnome/recipes-gnome/gdm/gdm/gdm.service
new file mode 100644
index 0000000000..72a56f954b
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gdm/gdm/gdm.service
@@ -0,0 +1,11 @@
+[Unit]
+Description=Gnome Display Manager
+Requires=dev-tty7.device
+After=dev-tty7.device systemd-user-sessions.service
+
+[Service]
+ExecStart=/usr/sbin/gdm -nodaemon
+StandardOutput=syslog
+
+[Install]
+WantedBy=graphical.target
diff --git a/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb b/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
index d24659aeed..e7c88630d9 100644
--- a/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
+++ b/meta-gnome/recipes-gnome/gdm/gdm_2.32.2.bb
@@ -4,6 +4,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
DEPENDS = "xinput gnome-panel tcp-wrappers libcanberra libxklavier grep consolekit libpam gnome-doc-utils gtk+ libglade libgnomecanvas librsvg libxml2 libart-lgpl xrdb"
+PR = "r1"
+
inherit gnome update-rc.d
SRC_URI += " \
@@ -13,6 +15,7 @@ SRC_URI += " \
file://gdm.conf \
file://gdm-pam \
file://Default \
+ file://gdm.service \
"
@@ -38,6 +41,31 @@ do_install_append() {
install -d ${D}/${sysconfdir}/gdm/Init
install -m 0755 ${WORKDIR}/Default ${D}/${sysconfdir}/gdm/Init
+
+ install -d ${D}${base_libdir}/systemd/system
+ install -m 0644 ${WORKDIR}/gdm.service ${D}${base_libdir}/systemd/system/
+}
+
+PACKAGES =+ "gdm-systemd"
+FILES_gdm-systemd = "${base_libdir}/systemd"
+RDEPENDS_gdm-systemd = "gdm"
+
+pkg_postinst_gdm-systemd() {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ systemctl enable gdm.service
+}
+
+pkg_postrm_gdm-systemd() {
+ # can't do this offline
+ if [ "x$D" != "x" ]; then
+ exit 1
+ fi
+
+ systemctl disable gdm.service
}
FILES_${PN} += "${datadir}/icon* \