aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-05-22 21:50:11 -0700
committerKhem Raj <raj.khem@gmail.com>2023-05-23 08:48:18 -0700
commitfcdb991b8015e77353517fb327d0def2a23b0173 (patch)
tree47942595310368d4e68c0c300b58cf16d01ac83e
parent9a06629463ebe8217a30011f9e94127a324d895c (diff)
downloadmeta-openembedded-fcdb991b8015e77353517fb327d0def2a23b0173.tar.gz
fftw: Check for TOOLCHAIN_OPTIONS to be non-empty before sed ops
Ensures that we do not apply empty sed expression which might happen when building native recipe Cc: jan vermaete <jan.vermaete@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/fftw/fftw_3.3.10.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/fftw/fftw_3.3.10.bb b/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
index 1fead4d029..33e8279880 100644
--- a/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
+++ b/meta-oe/recipes-support/fftw/fftw_3.3.10.bb
@@ -55,7 +55,7 @@ do_configure() {
do_compile() {
for lib in fftw fftwl fftwf; do
cd ${WORKDIR}/build-$lib
- sed -i -e 's|${TOOLCHAIN_OPTIONS}||g' config.h
+ test -n "${TOOLCHAIN_OPTIONS}" && sed -i -e 's|${TOOLCHAIN_OPTIONS}||g' config.h
autotools_do_compile
done
}