aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoronathan Richardson <jonathan.richardson@broadcom.com>2020-02-18 13:07:51 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-20 08:22:32 -0800
commitc58d9d500f90246d2d879e720fdfa5bbbc731c7f (patch)
treef152737b44cfc9c1ea9bdf0d141f2078c25bca90
parent28a3bbff54bf8974a4eae42870cb118151b04ebe (diff)
downloadmeta-openembedded-c58d9d500f90246d2d879e720fdfa5bbbc731c7f.tar.gz
fio: remove disabling of compiler optimizations
Disabling compiler optimizations affects fio performance by 25-30% so remove this from EXTRA_OECONF. Disabling of optimizations should be machine specific if there are bugs in the code instead of the default. Optimizations were removed in this commit: https://git.openembedded.org/meta-openembedded/commit/?id=739349da0826221f98648b64b693f9ae33e7d4ea Signed-off-by: Jonathan Richardson <jonathan.richardson@broadcom.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-benchmark/fio/fio_3.17.bb1
1 files changed, 0 insertions, 1 deletions
diff --git a/meta-oe/recipes-benchmark/fio/fio_3.17.bb b/meta-oe/recipes-benchmark/fio/fio_3.17.bb
index 482928c317..b15d7ba073 100644
--- a/meta-oe/recipes-benchmark/fio/fio_3.17.bb
+++ b/meta-oe/recipes-benchmark/fio/fio_3.17.bb
@@ -33,7 +33,6 @@ S = "${WORKDIR}/git"
DISABLE_STATIC = ""
EXTRA_OEMAKE = "CC='${CC}' LDFLAGS='${LDFLAGS}'"
-EXTRA_OECONF = "--disable-optimizations"
do_configure() {
./configure ${EXTRA_OECONF}