aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorzangrc <zangrc.fnst@fujitsu.com>2021-07-15 05:36:05 +0800
committerKhem Raj <raj.khem@gmail.com>2021-07-16 08:57:37 -0700
commit8f4ef229d8157f310478bb435be96aa338eee8d3 (patch)
treeb16d654ce6f731e255262dbcf1ce6a1b57d843c4
parentb2935f53c10a5d9895bb8c85e11d8d67c69a3c63 (diff)
downloadmeta-openembedded-8f4ef229d8157f310478bb435be96aa338eee8d3.tar.gz
python3-networkx: upgrade 2.5.1 -> 2.6.1
This release is the result of 11 months of work with over 363 pull requests by 91 contributors. Highlights include: Dropped support for Python 3.6. NumPy, SciPy, Matplotlib, and pandas are now default requirements. NetworkX no longer depends on the library “decorator”. Improved example gallery Removed code for supporting Jython/IronPython The __str__ method for graph objects is more informative and concise. Improved import time Improved test coverage New documentation theme Add functionality for drawing self-loop edges Add approximation algorithms for Traveling Salesman Problem New functions: Panther algorithm maximum cut heuristics equivalence_classes dedensification random_ordered_tree forest_str snap_aggregation networkx.approximation.diameter partition_quality prominent_group prefix_tree_recursive topological_generations -License-Update: Copyright year updated to 2021. Add runtime dependency to resolve errors that occurred when import networkx. Signed-off-by: Zang Ruochen <zangrc.fnst@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-networkx_2.5.1.bb12
-rw-r--r--meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb19
2 files changed, 19 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-networkx_2.5.1.bb b/meta-python/recipes-devtools/python/python3-networkx_2.5.1.bb
deleted file mode 100644
index 0b52cfd7e5..0000000000
--- a/meta-python/recipes-devtools/python/python3-networkx_2.5.1.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "Python package for creating and manipulating graphs and networks"
-HOMEPAGE = "http://networkx.github.io/"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=a24ea029adac8935699bf69b2e38c728"
-
-SRC_URI[sha256sum] = "109cd585cac41297f71103c3c42ac6ef7379f29788eb54cb751be5a663bb235a"
-
-inherit pypi setuptools3
-
-RDEPENDS_${PN} += "\
- ${PYTHON_PN}-decorator \
- "
diff --git a/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb b/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb
new file mode 100644
index 0000000000..676e1dbdca
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-networkx_2.6.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Python package for creating and manipulating graphs and networks"
+HOMEPAGE = "http://networkx.github.io/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5cfa4d8f5881e0d053bb497130b9c73a"
+
+SRC_URI[sha256sum] = "bf4cb807d1bccf1593c7d0742d9127d9e04e021867299082658b0fc3907924e8"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ ${PYTHON_PN}-decorator \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-compression \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-pickle \
+ ${PYTHON_PN}-html \
+ ${PYTHON_PN}-xml \
+ ${PYTHON_PN}-json \
+ "