aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorValentin Longchamp <valentin@longchamp.me>2021-03-30 17:21:46 +0200
committerKhem Raj <raj.khem@gmail.com>2021-03-30 12:38:55 -0700
commit86eb692a4e96b77857a4160a12625fc694812d52 (patch)
tree7abae85c5ed3bc2b387f8c16e510b833d367ee9f
parent120de5e02ae4d48bb75e910caa2b7f4ae4b3d025 (diff)
downloadmeta-openembedded-86eb692a4e96b77857a4160a12625fc694812d52.tar.gz
libssh: add gcrypt to PACKAGECONFIG
This would allow to build it without libgcrypt (relying instead on libcrypto). Enable it by default to keep the recipe behaving the same wihtout a configuration change. Signed-off-by: Valentin Longchamp <valentin@longchamp.me> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.8.9.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh_0.8.9.bb b/meta-oe/recipes-support/libssh/libssh_0.8.9.bb
index 39ed8a8fbb..2aff2c8781 100644
--- a/meta-oe/recipes-support/libssh/libssh_0.8.9.bb
+++ b/meta-oe/recipes-support/libssh/libssh_0.8.9.bb
@@ -4,7 +4,7 @@ SECTION = "libs"
LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=dabb4958b830e5df11d2b0ed8ea255a0"
-DEPENDS = "zlib openssl libgcrypt"
+DEPENDS = "zlib openssl"
SRC_URI = "git://git.libssh.org/projects/libssh.git;branch=stable-0.8"
SRCREV = "04685a74df9ce1db1bc116a83a0da78b4f4fa1f8"
@@ -13,13 +13,13 @@ S = "${WORKDIR}/git"
inherit cmake
-PACKAGECONFIG ??=""
+PACKAGECONFIG ??= "gcrypt"
PACKAGECONFIG[gssapi] = "-DWITH_GSSAPI=1, -DWITH_GSSAPI=0, krb5, "
+PACKAGECONFIG[gcrypt] = "-DWITH_GCRYPT=1, -DWITH_GCRYPT=0, libgcrypt, "
ARM_INSTRUCTION_SET_armv5 = "arm"
EXTRA_OECMAKE = " \
- -DWITH_GCRYPT=1 \
-DWITH_PCAP=1 \
-DWITH_SFTP=1 \
-DWITH_ZLIB=1 \