aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <bartosz.golaszewski@linaro.org>2023-03-27 20:48:26 +0200
committerKhem Raj <raj.khem@gmail.com>2023-03-28 10:44:00 -0700
commit3f06ba3c36603d545c799f8cd2a8276713cffcb4 (patch)
treed76b6c9fe8e981268043721306b11f7b44e47b7c
parent27995af89d2a0292398e83033adb1deb6fd75e4e (diff)
downloadmeta-openembedded-3f06ba3c36603d545c799f8cd2a8276713cffcb4.tar.gz
reboot-mode: new package
Add a recipe for the simple program that allows to replicate android reboot's behavior on linux (e.g. reboot bootloader, reboot recovery) as well as test reboot mode drivers in the linux kernel. Signed-off-by: Bartosz Golaszewski <bartosz.golaszewski@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb b/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
new file mode 100644
index 0000000000..20e77c63dc
--- /dev/null
+++ b/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Reboot the device to a specific mode."
+AUTHOR = "Daniele Debernardi <drebrez@gmail.com>"
+
+LICENSE = "GPL-3.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
+
+SRC_URI = "git://gitlab.com/postmarketOS/reboot-mode.git;protocol=http;branch=master"
+SRCREV = "84831b20512abd9033414ca5f5a023f333525335"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} reboot-mode.c -o reboot-mode
+}
+
+do_install() {
+ install -D -m 0755 ${S}/reboot-mode ${D}${bindir}/reboot-mode
+}