aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb b/meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb
new file mode 100644
index 0000000000..36a0191dc9
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-wtforms_3.0.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "A flexible forms validation and rendering library for python web development."
+HOMEPAGE = "https://pypi.python.org/pypi/WTForms"
+SECTION = "devel/python"
+LICENSE = "BSD-3-Clause"
+
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=53dbfa56f61b90215a9f8f0d527c043d"
+
+SRC_URI[sha256sum] = "6b351bbb12dd58af57ffef05bc78425d08d1914e0fd68ee14143b7ade023c5bc"
+
+PYPI_PACKAGE = "WTForms"
+
+inherit pypi setuptools3
+
+DEPENDS += "\
+ ${PYTHON_PN}-pip-native \
+ ${PYTHON_PN}-babel-native \
+ "
+
+RDEPENDS:${PN} += "\
+ ${PYTHON_PN}-netserver \
+ ${PYTHON_PN}-numbers \
+ ${PYTHON_PN}-markupsafe \
+ "