aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb b/meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb
new file mode 100644
index 0000000000..b926484db0
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-oslash_0.6.3.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Functors, Applicatives, And Monads in Python"
+HOMEPAGE = "https://github.com/dbrattli/oslash"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://README.md;md5=ed79d2637878dfe97de89e357b5c02dd"
+
+DEPENDS += "\
+ ${PYTHON_PN}-pip-native \
+ ${PYTHON_PN}-pytest-runner-native\
+"
+
+SRC_URI[sha256sum] = "868aeb58a656f2ed3b73d9dd6abe387b20b74fc9413d3e8653b615b15bf728f3"
+
+PYPI_PACKAGE = "OSlash"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += " \
+ python3-json \
+ python3-typing-extensions \
+"
+
+BBCLASSEXTEND = "native nativesdk"