aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch28
1 files changed, 14 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
index 899cac624a..aea8f62ea7 100644
--- a/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
+++ b/meta-python/recipes-devtools/python/python3-matplotlib/matplotlib-disable-download.patch
@@ -4,19 +4,17 @@ Upstream-Status: Inappropriate [disable feature]
Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
+Update patch to fit on 3.7.2.
+
+Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com>
+
+diff --git a/setup.py b/setup.py
+index 0bea13fa6f..f39d8fc871 100644
--- a/setup.py
+++ b/setup.py
-@@ -303,7 +303,6 @@ setup( # Finally, pass this all along t
- setup_requires=[
- "certifi>=2020.06.20",
- "numpy>=1.19",
-- "setuptools_scm>=7",
- ],
- install_requires=[
- "contourpy>=1.0.1",
-@@ -315,13 +314,7 @@ setup( # Finally, pass this all along t
+@@ -327,13 +327,7 @@ setup( # Finally, pass this all along to setuptools to do the heavy lifting.
"pillow>=6.2.0",
- "pyparsing>=2.2.1",
+ "pyparsing>=2.3.1,<3.1",
"python-dateutil>=2.7",
- ] + (
- # Installing from a git checkout that is not producing a wheel.
@@ -26,12 +24,14 @@ Signed-off-by: Mark Hatle <mark.hatle@xilinx.com>
- ) else []
- ),
+ ],
- use_scm_version={
- "version_scheme": "release-branch-semver",
- "local_scheme": "node-and-date",
+ extras_require={
+ ':python_version<"3.10"': [
+ "importlib-resources>=3.2.0",
+diff --git a/setupext.py b/setupext.py
+index a898d642d6..474172ff8f 100644
--- a/setupext.py
+++ b/setupext.py
-@@ -65,40 +65,7 @@ def get_from_cache_or_download(url, sha)
+@@ -66,40 +66,7 @@ def get_from_cache_or_download(url, sha):
BytesIO
The file loaded into memory.
"""