aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-test/googletest/googletest_1.13.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-test/googletest/googletest_1.13.0.bb')
-rw-r--r--meta-oe/recipes-test/googletest/googletest_1.13.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-test/googletest/googletest_1.13.0.bb b/meta-oe/recipes-test/googletest/googletest_1.13.0.bb
new file mode 100644
index 0000000000..2327f85d46
--- /dev/null
+++ b/meta-oe/recipes-test/googletest/googletest_1.13.0.bb
@@ -0,0 +1,28 @@
+DESCRIPTION = "Google's framework for writing C++ tests"
+HOMEPAGE = "https://github.com/google/googletest"
+SECTION = "libs"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cbbd27594afd089daa160d3a16dd515a"
+
+PROVIDES += "gmock gtest"
+
+S = "${WORKDIR}/git"
+SRCREV = "b796f7d44681514f58a683a3a71ff17c94edb0c1"
+SRC_URI = "git://github.com/google/googletest.git;branch=main;protocol=https"
+
+inherit cmake
+
+ALLOW_EMPTY:${PN} = "1"
+ALLOW_EMPTY:${PN}-dbg = "1"
+
+RDEPENDS:${PN}-dev += "${PN}-staticdev"
+
+BBCLASSEXTEND = "native nativesdk"
+
+do_configure:prepend() {
+ # explicitly use python3
+ # the scripts are already python3 compatible since https://github.com/google/googletest/commit/d404af0d987a9c38cafce82a7e26ec8468c88361 and other fixes like this
+ # but since this oe-core change http://git.openembedded.org/openembedded-core/commit/?id=5f8f16b17f66966ae91aeabc23e97de5ecd17447
+ # there isn't python in HOSTTOOLS so "env python" fails
+ sed -i 's@^#!/usr/bin/env python$@#!/usr/bin/env python3@g' ${S}/googlemock/test/*py ${S}/googletest/test/*py
+}