aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb')
-rw-r--r--meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb b/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
new file mode 100644
index 0000000000..4c3436823a
--- /dev/null
+++ b/meta-oe/recipes-support/reboot-mode/reboot-mode_git.bb
@@ -0,0 +1,18 @@
+SUMMARY = "Reboot the device to a specific mode."
+AUTHOR = "Daniele Debernardi <drebrez@gmail.com>"
+
+LICENSE = "GPL-3.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=84dcc94da3adb52b53ae4fa38fe49e5d"
+
+SRC_URI = "git://gitlab.com/postmarketOS/reboot-mode.git;protocol=http;branch=master"
+SRCREV = "84831b20512abd9033414ca5f5a023f333525335"
+
+S = "${WORKDIR}/git"
+
+do_compile() {
+ ${CC} ${CFLAGS} ${LDFLAGS} ${S}/reboot-mode.c -o ${B}/reboot-mode
+}
+
+do_install() {
+ install -D -m 0755 ${B}/reboot-mode ${D}${bindir}/reboot-mode
+}