aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_git.bb3
-rw-r--r--meta-oe/recipes-graphics/fbida/files/0001-meson.build-install-fbgs-shell-script.patch8
-rw-r--r--meta-oe/recipes-graphics/fbida/files/0002-meson.build-add-features-options-for-png-gif-tiff-we.patch23
-rw-r--r--meta-oe/recipes-graphics/fbida/files/0003-meson.build-do-not-require-xkbcommon.patch27
4 files changed, 46 insertions, 15 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_git.bb b/meta-oe/recipes-graphics/fbida/fbida_git.bb
index f686779f9f..784485052d 100644
--- a/meta-oe/recipes-graphics/fbida/fbida_git.bb
+++ b/meta-oe/recipes-graphics/fbida/fbida_git.bb
@@ -17,8 +17,9 @@ SRC_URI = "git://github.com/kraxel/fbida;protocol=https;branch=master \
file://fbida-gcc10.patch \
file://0001-meson.build-install-fbgs-shell-script.patch \
file://0002-meson.build-add-features-options-for-png-gif-tiff-we.patch \
+ file://0003-meson.build-do-not-require-xkbcommon.patch \
"
-SRCREV = "ac9005bf0bbf50f14dc1b368be5084c8e0510a5d"
+SRCREV = "eb769e3d7f4a073d4c37ed524ebd5017c6a578f5"
S = "${WORKDIR}/git"
inherit meson pkgconfig features_check
diff --git a/meta-oe/recipes-graphics/fbida/files/0001-meson.build-install-fbgs-shell-script.patch b/meta-oe/recipes-graphics/fbida/files/0001-meson.build-install-fbgs-shell-script.patch
index 06ec5dfd81..d686def3d2 100644
--- a/meta-oe/recipes-graphics/fbida/files/0001-meson.build-install-fbgs-shell-script.patch
+++ b/meta-oe/recipes-graphics/fbida/files/0001-meson.build-install-fbgs-shell-script.patch
@@ -3,6 +3,8 @@ From: "Meyer, Wolfgang" <Wolfgang.Meyer@gossenmetrawatt.com>
Date: Fri, 9 Sep 2022 09:32:22 +0200
Subject: [PATCH] meson.build: install fbgs shell script
+Upstream-Status: Pending
+Signed-off-by: "Meyer, Wolfgang" <Wolfgang.Meyer@gossenmetrawatt.com>
---
meson.build | 3 +++
1 file changed, 3 insertions(+)
@@ -11,7 +13,7 @@ diff --git a/meson.build b/meson.build
index cbed982..2129896 100644
--- a/meson.build
+++ b/meson.build
-@@ -124,6 +124,9 @@ executable('fbpdf',
+@@ -126,6 +126,9 @@ executable('fbpdf',
sources : fbpdf_srcs,
dependencies : fbpdf_deps,
install : true)
@@ -19,8 +21,8 @@ index cbed982..2129896 100644
+ install_dir : get_option('bindir'),
+ install_mode : 'rwxr--r--')
- # build kbdtest
- executable('kbdtest',
+ # build fbcon
+ fbcon_srcs = [ 'fbcon.c', 'drmtools.c', 'fbtools.c', 'gfx.c', 'vt.c', 'kbd.c' ]
--
2.37.3
diff --git a/meta-oe/recipes-graphics/fbida/files/0002-meson.build-add-features-options-for-png-gif-tiff-we.patch b/meta-oe/recipes-graphics/fbida/files/0002-meson.build-add-features-options-for-png-gif-tiff-we.patch
index 92f034c520..fe36fcb7cb 100644
--- a/meta-oe/recipes-graphics/fbida/files/0002-meson.build-add-features-options-for-png-gif-tiff-we.patch
+++ b/meta-oe/recipes-graphics/fbida/files/0002-meson.build-add-features-options-for-png-gif-tiff-we.patch
@@ -1,9 +1,10 @@
-From fa60c06cadd6acd8abede91e75254e7250a087a3 Mon Sep 17 00:00:00 2001
+From cdcde5c1fd106a69118dff98118600911392762f Mon Sep 17 00:00:00 2001
From: "Meyer, Wolfgang" <Wolfgang.Meyer@gossenmetrawatt.com>
-Date: Fri, 16 Sep 2022 13:40:25 +0200
-Subject: [PATCH] meson.build: add features options for png, gif, tiff, webp,
- and motif
+Date: Fri, 16 Sep 2022 16:25:38 +0200
+Subject: [PATCH] meson.build: add features options for png, gif, tiff, webp, and motif
+Upstream-Status: Pending
+Signed-off-by: "Meyer, Wolfgang" <Wolfgang.Meyer@gossenmetrawatt.com>
---
meson.build | 41 +++++++++++++++++++++++++++--------------
meson_options.txt | 5 +++++
@@ -12,10 +13,10 @@ Subject: [PATCH] meson.build: add features options for png, gif, tiff, webp,
create mode 100644 meson_options.txt
diff --git a/meson.build b/meson.build
-index cbed982..e66ee48 100644
+index cd9cc49..b5e3ffc 100644
--- a/meson.build
+++ b/meson.build
-@@ -21,9 +21,9 @@ drm_dep = dependency('libdrm')
+@@ -23,9 +23,9 @@ drm_dep = dependency('libdrm')
gbm_dep = dependency('gbm')
epoxy_dep = dependency('epoxy')
exif_dep = dependency('libexif')
@@ -27,9 +28,9 @@ index cbed982..e66ee48 100644
+webp_dep = dependency('libwebp', required : get_option('webp'))
udev_dep = dependency('libudev')
input_dep = dependency('libinput')
-
-@@ -32,20 +32,20 @@ cc = meson.get_compiler('c')
- jpeg_dep = cc.find_library('jpeg')
+ xkb_dep = dependency('xkbcommon')
+@@ -36,20 +36,20 @@ jpeg_dep = cc.find_library('jpeg')
+ util_dep = cc.find_library('util')
math_dep = cc.find_library('m', required : false)
pcd_dep = cc.find_library('pcd', required : false)
-gif_dep = cc.find_library('gif', required : false)
@@ -57,7 +58,7 @@ index cbed982..e66ee48 100644
image_deps = [ jpeg_dep, png_dep, tiff_dep,
pcd_dep, gif_dep, webp_dep ]
-@@ -53,11 +53,21 @@ if pcd_dep.found()
+@@ -57,11 +57,21 @@ if pcd_dep.found()
read_srcs += 'rd/read-pcd.c'
config.set('HAVE_LIBPCD', true)
endif
@@ -81,7 +82,7 @@ index cbed982..e66ee48 100644
read_srcs += 'rd/read-webp.c'
config.set('HAVE_LIBWEBP', true)
endif
-@@ -153,7 +166,7 @@ ida_srcs = [ 'ida.c', 'man.c', 'hex.c', 'x11.c', 'viewer.c',
+@@ -168,7 +181,7 @@ ida_srcs = [ 'ida.c', 'man.c', 'hex.c', 'x11.c', 'viewer.c',
ida_deps = [ pixman_dep, exif_dep, image_deps, math_dep,
motif_dep, xpm_dep, xt_dep, xext_dep, x11_dep ]
diff --git a/meta-oe/recipes-graphics/fbida/files/0003-meson.build-do-not-require-xkbcommon.patch b/meta-oe/recipes-graphics/fbida/files/0003-meson.build-do-not-require-xkbcommon.patch
new file mode 100644
index 0000000000..e769014131
--- /dev/null
+++ b/meta-oe/recipes-graphics/fbida/files/0003-meson.build-do-not-require-xkbcommon.patch
@@ -0,0 +1,27 @@
+From ec82a194f3454ac203a134c9a99bac6d63095d25 Mon Sep 17 00:00:00 2001
+From: "Meyer, Wolfgang" <Wolfgang.Meyer@gossenmetrawatt.com>
+Date: Fri, 16 Sep 2022 18:29:03 +0200
+Subject: [PATCH] meson.build: do not require xkbcommon
+
+Upstream-Status: Pending
+Signed-off-by: "Meyer, Wolfgang" <Wolfgang.Meyer@gossenmetrawatt.com>
+---
+ meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 341939c..b5dab14 100644
+--- a/meson.build
++++ b/meson.build
+@@ -26,7 +26,7 @@ tiff_dep = dependency('libtiff-4', required: get_option('tiff'))
+ webp_dep = dependency('libwebp', required : get_option('webp'))
+ udev_dep = dependency('libudev')
+ input_dep = dependency('libinput')
+-xkb_dep = dependency('xkbcommon')
++xkb_dep = dependency('xkbcommon', required : false)
+ tsm_dep = dependency('libtsm', required : false)
+
+ # other library deps
+--
+2.37.3
+