aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-gnome/gnome
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-gnome/gnome')
-rw-r--r--meta-oe/recipes-gnome/gnome/files/acinclude.m490
-rw-r--r--meta-oe/recipes-gnome/gnome/files/gtk-doc.m453
-rw-r--r--meta-oe/recipes-gnome/gnome/files/gtk-doc.make173
-rw-r--r--meta-oe/recipes-gnome/gnome/files/libproxy-move-define-__USE_BSD.patch17
-rw-r--r--meta-oe/recipes-gnome/gnome/files/tasn.m4161
-rw-r--r--meta-oe/recipes-gnome/gnome/gconf-native_2.6.1.bb17
-rw-r--r--meta-oe/recipes-gnome/gnome/gconf_2.28.0.bb40
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2-2.14.17/configure-lossage.patch37
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2-native_2.14.12.bb27
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2.inc32
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2/configure-lossage.patch35
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2/pkgconfig-fix.patch12
-rw-r--r--meta-oe/recipes-gnome/gnome/orbit2_2.14.17.bb5
13 files changed, 699 insertions, 0 deletions
diff --git a/meta-oe/recipes-gnome/gnome/files/acinclude.m4 b/meta-oe/recipes-gnome/gnome/files/acinclude.m4
new file mode 100644
index 0000000000..53518fb2eb
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/acinclude.m4
@@ -0,0 +1,90 @@
+## this one is commonly used with AM_PATH_PYTHONDIR ...
+dnl AM_CHECK_PYMOD(MODNAME [,SYMBOL [,ACTION-IF-FOUND [,ACTION-IF-NOT-FOUND]]])
+dnl Check if a module containing a given symbol is visible to python.
+AC_DEFUN(AM_CHECK_PYMOD,
+[AC_REQUIRE([AM_PATH_PYTHON])
+py_mod_var=`echo $1['_']$2 | sed 'y%./+-%__p_%'`
+AC_MSG_CHECKING(for ifelse([$2],[],,[$2 in ])python module $1)
+AC_CACHE_VAL(py_cv_mod_$py_mod_var, [
+ifelse([$2],[], [prog="
+import sys
+try:
+ import $1
+except ImportError:
+ sys.exit(1)
+except:
+ sys.exit(0)
+sys.exit(0)"], [prog="
+import $1
+$1.$2"])
+if $PYTHON -c "$prog" 1>&AC_FD_CC 2>&AC_FD_CC
+ then
+ eval "py_cv_mod_$py_mod_var=yes"
+ else
+ eval "py_cv_mod_$py_mod_var=no"
+ fi
+])
+py_val=`eval "echo \`echo '$py_cv_mod_'$py_mod_var\`"`
+if test "x$py_val" != xno; then
+ AC_MSG_RESULT(yes)
+ ifelse([$3], [],, [$3
+])dnl
+else
+ AC_MSG_RESULT(no)
+ ifelse([$4], [],, [$4
+])dnl
+fi
+])
+
+dnl a macro to check for ability to create python extensions
+dnl AM_CHECK_PYTHON_HEADERS([ACTION-IF-POSSIBLE], [ACTION-IF-NOT-POSSIBLE])
+dnl function also defines PYTHON_INCLUDES
+AC_DEFUN([AM_CHECK_PYTHON_HEADERS],
+[AC_REQUIRE([AM_PATH_PYTHON])
+AC_MSG_CHECKING(for headers required to compile python extensions)
+dnl deduce PYTHON_INCLUDES
+AC_ARG_WITH(python-includes,
+ [ --with-python-includes=DIR path to Python includes], py_exec_prefix=$withval)
+if test x$py_exec_prefix != x; then
+PYTHON_INCLUDES="-I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+else
+py_prefix=`$PYTHON -c "import sys; print sys.prefix"`
+py_exec_prefix=`$PYTHON -c "import sys; print sys.exec_prefix"`
+PYTHON_INCLUDES="-I${py_prefix}/include/python${PYTHON_VERSION}"
+if test "$py_prefix" != "$py_exec_prefix"; then
+ PYTHON_INCLUDES="$PYTHON_INCLUDES -I${py_exec_prefix}/include/python${PYTHON_VERSION}"
+fi
+fi
+AC_SUBST(PYTHON_INCLUDES)
+dnl check if the headers exist:
+save_CPPFLAGS="$CPPFLAGS"
+CPPFLAGS="$CPPFLAGS $PYTHON_INCLUDES"
+AC_TRY_CPP([#include <Python.h>],dnl
+[AC_MSG_RESULT(found)
+$1],dnl
+[AC_MSG_RESULT(not found)
+$2])
+CPPFLAGS="$save_CPPFLAGS"
+])
+
+dnl
+dnl JH_ADD_CFLAG(FLAG)
+dnl checks whether the C compiler supports the given flag, and if so, adds
+dnl it to $CFLAGS. If the flag is already present in the list, then the
+dnl check is not performed.
+AC_DEFUN([JH_ADD_CFLAG],
+[
+case " $CFLAGS " in
+*@<:@\ \ @:>@$1@<:@\ \ @:>@*)
+ ;;
+*)
+ save_CFLAGS="$CFLAGS"
+ CFLAGS="$CFLAGS $1"
+ AC_MSG_CHECKING([whether [$]CC understands $1])
+ AC_TRY_COMPILE([], [], [jh_has_option=yes], [jh_has_option=no])
+ AC_MSG_RESULT($jh_has_option)
+ if test $jh_has_option = no; then
+ CFLAGS="$save_CFLAGS"
+ fi
+ ;;
+esac])
diff --git a/meta-oe/recipes-gnome/gnome/files/gtk-doc.m4 b/meta-oe/recipes-gnome/gnome/files/gtk-doc.m4
new file mode 100644
index 0000000000..3ec41666b2
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/gtk-doc.m4
@@ -0,0 +1,53 @@
+dnl -*- mode: autoconf -*-
+
+# serial 1
+
+dnl Usage:
+dnl GTK_DOC_CHECK([minimum-gtk-doc-version])
+AC_DEFUN([GTK_DOC_CHECK],
+[
+ AC_BEFORE([AC_PROG_LIBTOOL],[$0])dnl setup libtool first
+ AC_BEFORE([AM_PROG_LIBTOOL],[$0])dnl setup libtool first
+ dnl for overriding the documentation installation directory
+ AC_ARG_WITH(html-dir,
+ AC_HELP_STRING([--with-html-dir=PATH], [path to installed docs]),,
+ [with_html_dir='${datadir}/gtk-doc/html'])
+ HTML_DIR="$with_html_dir"
+ AC_SUBST(HTML_DIR)
+
+ dnl enable/disable documentation building
+ AC_ARG_ENABLE(gtk-doc,
+ AC_HELP_STRING([--enable-gtk-doc],
+ [use gtk-doc to build documentation [default=no]]),,
+ enable_gtk_doc=no)
+
+ have_gtk_doc=no
+ if test -z "$PKG_CONFIG"; then
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+ fi
+ if test "$PKG_CONFIG" != "no" && $PKG_CONFIG --exists gtk-doc; then
+ have_gtk_doc=yes
+ fi
+
+ dnl do we want to do a version check?
+ifelse([$1],[],,
+ [gtk_doc_min_version=$1
+ if test "$have_gtk_doc" = yes; then
+ AC_MSG_CHECKING([gtk-doc version >= $gtk_doc_min_version])
+ if $PKG_CONFIG --atleast-version $gtk_doc_min_version gtk-doc; then
+ AC_MSG_RESULT(yes)
+ else
+ AC_MSG_RESULT(no)
+ have_gtk_doc=no
+ fi
+ fi
+])
+ if test x$enable_gtk_doc = xyes; then
+ if test "$have_gtk_doc" != yes; then
+ enable_gtk_doc=no
+ fi
+ fi
+
+ AM_CONDITIONAL(ENABLE_GTK_DOC, test x$enable_gtk_doc = xyes)
+ AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, test -n "$LIBTOOL")
+])
diff --git a/meta-oe/recipes-gnome/gnome/files/gtk-doc.make b/meta-oe/recipes-gnome/gnome/files/gtk-doc.make
new file mode 100644
index 0000000000..354ffb7c66
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/gtk-doc.make
@@ -0,0 +1,173 @@
+# -*- mode: makefile -*-
+
+####################################
+# Everything below here is generic #
+####################################
+
+if GTK_DOC_USE_LIBTOOL
+GTKDOC_CC = $(LIBTOOL) --mode=compile $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+GTKDOC_LD = $(LIBTOOL) --mode=link $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
+else
+GTKDOC_CC = $(CC) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
+GTKDOC_LD = $(CC) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS)
+endif
+
+# We set GPATH here; this gives us semantics for GNU make
+# which are more like other make's VPATH, when it comes to
+# whether a source that is a target of one rule is then
+# searched for in VPATH/GPATH.
+#
+GPATH = $(srcdir)
+
+TARGET_DIR=$(HTML_DIR)/$(DOC_MODULE)
+
+EXTRA_DIST = \
+ $(content_files) \
+ $(HTML_IMAGES) \
+ $(DOC_MAIN_SGML_FILE) \
+ $(DOC_MODULE)-sections.txt \
+ $(DOC_MODULE)-overrides.txt
+
+DOC_STAMPS=scan-build.stamp tmpl-build.stamp sgml-build.stamp html-build.stamp \
+ $(srcdir)/tmpl.stamp $(srcdir)/sgml.stamp $(srcdir)/html.stamp
+
+SCANOBJ_FILES = \
+ $(DOC_MODULE).args \
+ $(DOC_MODULE).hierarchy \
+ $(DOC_MODULE).interfaces \
+ $(DOC_MODULE).prerequisites \
+ $(DOC_MODULE).signals
+
+REPORT_FILES = \
+ $(DOC_MODULE)-undocumented.txt \
+ $(DOC_MODULE)-undeclared.txt \
+ $(DOC_MODULE)-unused.txt
+
+CLEANFILES = $(SCANOBJ_FILES) $(REPORT_FILES) $(DOC_STAMPS)
+
+if ENABLE_GTK_DOC
+all-local: html-build.stamp
+else
+all-local:
+endif
+
+docs: html-build.stamp
+
+#### scan ####
+
+scan-build.stamp: $(HFILE_GLOB) $(CFILE_GLOB)
+ @echo 'gtk-doc: Scanning header files'
+ @-chmod -R u+w $(srcdir)
+ cd $(srcdir) && \
+ gtkdoc-scan --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --ignore-headers="$(IGNORE_HFILES)" $(SCAN_OPTIONS) $(EXTRA_HFILES)
+ if grep -l '^..*$$' $(srcdir)/$(DOC_MODULE).types > /dev/null 2>&1 ; then \
+ CC="$(GTKDOC_CC)" LD="$(GTKDOC_LD)" CFLAGS="$(GTKDOC_CFLAGS)" LDFLAGS="$(GTKDOC_LIBS)" gtkdoc-scangobj $(SCANGOBJ_OPTIONS) --module=$(DOC_MODULE) --output-dir=$(srcdir) ; \
+ else \
+ cd $(srcdir) ; \
+ for i in $(SCANOBJ_FILES) ; do \
+ test -f $$i || touch $$i ; \
+ done \
+ fi
+ touch scan-build.stamp
+
+$(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt: scan-build.stamp
+ @true
+
+#### templates ####
+
+tmpl-build.stamp: $(DOC_MODULE)-decl.txt $(SCANOBJ_FILES) $(DOC_MODULE)-sections.txt $(DOC_MODULE)-overrides.txt
+ @echo 'gtk-doc: Rebuilding template files'
+ @-chmod -R u+w $(srcdir)
+ cd $(srcdir) && gtkdoc-mktmpl --module=$(DOC_MODULE) $(MKTMPL_OPTIONS)
+ touch tmpl-build.stamp
+
+tmpl.stamp: tmpl-build.stamp
+ @true
+
+tmpl/*.sgml:
+ @true
+
+
+#### xml ####
+
+sgml-build.stamp: tmpl.stamp $(HFILE_GLOB) $(CFILE_GLOB) $(DOC_MODULE)-sections.txt $(srcdir)/tmpl/*.sgml $(expand_content_files)
+ @echo 'gtk-doc: Building XML'
+ @-chmod -R u+w $(srcdir)
+ cd $(srcdir) && \
+ gtkdoc-mkdb --module=$(DOC_MODULE) --source-dir=$(DOC_SOURCE_DIR) --output-format=xml --expand-content-files="$(expand_content_files)" --main-sgml-file=$(DOC_MAIN_SGML_FILE) $(MKDB_OPTIONS)
+ touch sgml-build.stamp
+
+sgml.stamp: sgml-build.stamp
+ @true
+
+#### html ####
+
+html-build.stamp: sgml.stamp $(DOC_MAIN_SGML_FILE) $(content_files)
+ @echo 'gtk-doc: Building HTML'
+ @-chmod -R u+w $(srcdir)
+ rm -rf $(srcdir)/html
+ mkdir $(srcdir)/html
+ cd $(srcdir)/html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
+ test "x$(HTML_IMAGES)" = "x" || ( cd $(srcdir) && cp $(HTML_IMAGES) html )
+ @echo 'gtk-doc: Fixing cross-references'
+ cd $(srcdir) && gtkdoc-fixxref --module-dir=html --html-dir=$(HTML_DIR) $(FIXXREF_OPTIONS)
+ touch html-build.stamp
+
+##############
+
+clean-local:
+ rm -f *~ *.bak
+ rm -rf .libs
+
+distclean-local:
+ cd $(srcdir) && \
+ rm -rf xml $(REPORT_FILES) \
+ $(DOC_MODULE)-decl-list.txt $(DOC_MODULE)-decl.txt
+
+maintainer-clean-local: clean
+ cd $(srcdir) && rm -rf xml html
+
+install-data-local:
+ -installfiles=`echo $(srcdir)/html/*`; \
+ if test "$$installfiles" = '$(srcdir)/html/*'; \
+ then echo '-- Nothing to install' ; \
+ else \
+ $(mkinstalldirs) $(DESTDIR)$(TARGET_DIR); \
+ for i in $$installfiles; do \
+ echo '-- Installing '$$i ; \
+ $(INSTALL_DATA) $$i $(DESTDIR)$(TARGET_DIR); \
+ done; \
+ echo '-- Installing $(srcdir)/html/index.sgml' ; \
+ $(INSTALL_DATA) $(srcdir)/html/index.sgml $(DESTDIR)$(TARGET_DIR) || :; \
+ which gtkdoc-rebase >/dev/null && \
+ gtkdoc-rebase --relative --dest-dir=$(DESTDIR) --html-dir=$(DESTDIR)$(TARGET_DIR) ; \
+ fi
+
+
+uninstall-local:
+ rm -f $(DESTDIR)$(TARGET_DIR)/*
+
+#
+# Require gtk-doc when making dist
+#
+if ENABLE_GTK_DOC
+dist-check-gtkdoc:
+else
+dist-check-gtkdoc:
+ @echo "*** gtk-doc must be installed and enabled in order to make dist"
+ @false
+endif
+
+dist-hook: dist-check-gtkdoc dist-hook-local
+ mkdir $(distdir)/tmpl
+ mkdir $(distdir)/xml
+ mkdir $(distdir)/html
+ -cp $(srcdir)/tmpl/*.sgml $(distdir)/tmpl
+ -cp $(srcdir)/xml/*.xml $(distdir)/xml
+ cp $(srcdir)/html/* $(distdir)/html
+ -cp $(srcdir)/$(DOC_MODULE).types $(distdir)/
+ -cp $(srcdir)/$(DOC_MODULE)-sections.txt $(distdir)/
+ cd $(distdir) && rm -f $(DISTCLEANFILES)
+ -gtkdoc-rebase --online --relative --html-dir=$(distdir)/html
+
+.PHONY : dist-hook-local docs
diff --git a/meta-oe/recipes-gnome/gnome/files/libproxy-move-define-__USE_BSD.patch b/meta-oe/recipes-gnome/gnome/files/libproxy-move-define-__USE_BSD.patch
new file mode 100644
index 0000000000..b65b3608d4
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/libproxy-move-define-__USE_BSD.patch
@@ -0,0 +1,17 @@
+Index: libproxy-0.2.3/src/lib/dns.c
+===================================================================
+--- libproxy-0.2.3.orig/src/lib/dns.c 2009-08-14 14:13:21.123557812 -0700
++++ libproxy-0.2.3/src/lib/dns.c 2009-08-14 14:13:31.954575500 -0700
+@@ -17,11 +17,11 @@
+ * Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+ ******************************************************************************/
+
++#define __USE_BSD
+ #include <string.h>
+ #include <errno.h>
+ #include <stdio.h>
+ #include <netdb.h>
+-#define __USE_BSD
+ #include <unistd.h>
+
+ #include "misc.h"
diff --git a/meta-oe/recipes-gnome/gnome/files/tasn.m4 b/meta-oe/recipes-gnome/gnome/files/tasn.m4
new file mode 100644
index 0000000000..6df32085a8
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/files/tasn.m4
@@ -0,0 +1,161 @@
+dnl Autoconf macros for libtasn1
+dnl $id$
+
+# Modified for LIBTASN1 -- nmav
+# Configure paths for LIBGCRYPT
+# Shamelessly stolen from the one of XDELTA by Owen Taylor
+# Werner Koch 99-12-09
+
+dnl AM_PATH_LIBTASN1([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
+dnl Test for libtasn1, and define LIBTASN1_CFLAGS and LIBTASN1_LIBS
+dnl
+AC_DEFUN([AM_PATH_LIBTASN1],
+[dnl
+dnl Get the cflags and libraries from the libtasn1-config script
+dnl
+AC_ARG_WITH(libtasn1-prefix,
+ [ --with-libtasn1-prefix=PFX Prefix where libtasn1 is installed (optional)],
+ libtasn1_config_prefix="$withval", libtasn1_config_prefix="")
+
+ if test x$libtasn1_config_prefix != x ; then
+ if test x${LIBTASN1_CONFIG+set} != xset ; then
+ LIBTASN1_CONFIG=$libtasn1_config_prefix/bin/libtasn1-config
+ fi
+ fi
+
+ AC_PATH_PROG(LIBTASN1_CONFIG, libtasn1-config, no)
+ min_libtasn1_version=ifelse([$1], ,0.1.0,$1)
+ AC_MSG_CHECKING(for libtasn1 - version >= $min_libtasn1_version)
+ no_libtasn1=""
+ if test "$LIBTASN1_CONFIG" = "no" ; then
+ no_libtasn1=yes
+ else
+ LIBTASN1_CFLAGS=`$LIBTASN1_CONFIG $libtasn1_config_args --cflags`
+ LIBTASN1_LIBS=`$LIBTASN1_CONFIG $libtasn1_config_args --libs`
+ libtasn1_config_version=`$LIBTASN1_CONFIG $libtasn1_config_args --version`
+
+
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $LIBTASN1_CFLAGS"
+ LIBS="$LIBS $LIBTASN1_LIBS"
+dnl
+dnl Now check if the installed libtasn1 is sufficiently new. Also sanity
+dnl checks the results of libtasn1-config to some extent
+dnl
+ rm -f conf.libtasn1test
+ AC_TRY_RUN([
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <libtasn1.h>
+
+int
+main ()
+{
+ system ("touch conf.libtasn1test");
+
+ if( strcmp( asn1_check_version(NULL), "$libtasn1_config_version" ) )
+ {
+ printf("\n*** 'libtasn1-config --version' returned %s, but LIBTASN1 (%s)\n",
+ "$libtasn1_config_version", asn1_check_version(NULL) );
+ printf("*** was found! If libtasn1-config was correct, then it is best\n");
+ printf("*** to remove the old version of LIBTASN1. You may also be able to fix the error\n");
+ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
+ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
+ printf("*** required on your system.\n");
+ printf("*** If libtasn1-config was wrong, set the environment variable LIBTASN1_CONFIG\n");
+ printf("*** to point to the correct copy of libtasn1-config, and remove the file config.cache\n");
+ printf("*** before re-running configure\n");
+ }
+ else if ( strcmp(asn1_check_version(NULL), LIBTASN1_VERSION ) )
+ {
+ printf("\n*** LIBTASN1 header file (version %s) does not match\n", LIBTASN1_VERSION);
+ printf("*** library (version %s)\n", asn1_check_version(NULL) );
+ }
+ else
+ {
+ if ( asn1_check_version( "$min_libtasn1_version" ) )
+ {
+ return 0;
+ }
+ else
+ {
+ printf("no\n*** An old version of LIBTASN1 (%s) was found.\n",
+ asn1_check_version(NULL) );
+ printf("*** You need a version of LIBTASN1 newer than %s. The latest version of\n",
+ "$min_libtasn1_version" );
+ printf("*** LIBTASN1 is always available from ftp://gnutls.hellug.gr/pub/gnutls/libtasn1.\n");
+ printf("*** \n");
+ printf("*** If you have already installed a sufficiently new version, this error\n");
+ printf("*** probably means that the wrong copy of the libtasn1-config shell script is\n");
+ printf("*** being found. The easiest way to fix this is to remove the old version\n");
+ printf("*** of LIBTASN1, but you can also set the LIBTASN1_CONFIG environment to point to the\n");
+ printf("*** correct copy of libtasn1-config. (In this case, you will have to\n");
+ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
+ printf("*** so that the correct libraries are found at run-time))\n");
+ }
+ }
+ return 0;
+}
+],, no_libtasn1=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+
+ if test "x$no_libtasn1" = x ; then
+ AC_MSG_RESULT(yes)
+ ifelse([$2], , :, [$2])
+ else
+ if test -f conf.libtasn1test ; then
+ :
+ else
+ AC_MSG_RESULT(no)
+ fi
+ if test "$LIBTASN1_CONFIG" = "no" ; then
+ echo "*** The libtasn1-config script installed by LIBTASN1 could not be found"
+ echo "*** If LIBTASN1 was installed in PREFIX, make sure PREFIX/bin is in"
+ echo "*** your path, or set the LIBTASN1_CONFIG environment variable to the"
+ echo "*** full path to libtasn1-config."
+ else
+ if test -f conf.libtasn1test ; then
+ :
+ else
+ echo "*** Could not run libtasn1 test program, checking why..."
+ CFLAGS="$CFLAGS $LIBTASN1_CFLAGS"
+ LIBS="$LIBS $LIBTASN1_LIBS"
+ AC_TRY_LINK([
+#include <stdio.h>
+#include <stdlib.h>
+#include <string.h>
+#include <libtasn1.h>
+], [ return !!asn1_check_version(NULL); ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding LIBTASN1 or finding the wrong"
+ echo "*** version of LIBTASN1. If it is not finding LIBTASN1, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH"
+ echo "***" ],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means LIBTASN1 was incorrectly installed"
+ echo "*** or that you have moved LIBTASN1 since it was installed. In the latter case, you"
+ echo "*** may want to edit the libtasn1-config script: $LIBTASN1_CONFIG" ])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ LIBTASN1_CFLAGS=""
+ LIBTASN1_LIBS=""
+ ifelse([$3], , :, [$3])
+ fi
+ rm -f conf.libtasn1test
+ AC_SUBST(LIBTASN1_CFLAGS)
+ AC_SUBST(LIBTASN1_LIBS)
+])
+
+dnl *-*wedit:notab*-* Please keep this as the last line.
+
diff --git a/meta-oe/recipes-gnome/gnome/gconf-native_2.6.1.bb b/meta-oe/recipes-gnome/gnome/gconf-native_2.6.1.bb
new file mode 100644
index 0000000000..fac712395d
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gconf-native_2.6.1.bb
@@ -0,0 +1,17 @@
+NOTE = "This is just a dummy package to get packages stop complaining about gconftool-2 \
+ which they are not using anyway... :D"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${POKYBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
+
+PR = "r1"
+
+inherit native
+
+do_install() {
+ install -d ${D}${bindir}
+ echo "#!/bin/sh" >${D}${bindir}/gconftool-2
+ chmod a+rx ${D}${bindir}/gconftool-2
+}
+
+NATIVE_INSTALL_WORKS = "1"
diff --git a/meta-oe/recipes-gnome/gnome/gconf_2.28.0.bb b/meta-oe/recipes-gnome/gnome/gconf_2.28.0.bb
new file mode 100644
index 0000000000..e167d8a6d5
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/gconf_2.28.0.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "GNOME configuration database system"
+SECTION = "x11/gnome"
+DEPENDS = "gtk+ orbit2 glib-2.0 libxml2 policykit"
+ORBIT_IDL_SRC = "${STAGING_BINDIR_NATIVE}/orbit-idl-2"
+
+LICENSE = "LGPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
+
+S = "${WORKDIR}/GConf-${PV}"
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/GConf/2.28/GConf-${PV}.tar.bz2;name=archive"
+SRC_URI[archive.md5sum] = "ad2aeb9c7d906b274954c51a615caeac"
+SRC_URI[archive.sha256sum] = "d057dcfe2bfb2a80e592349c2a78d7dce12d19542aeced466c64fb701c806ac8"
+
+PR = "r2"
+
+RDEPENDS_${PN} += "dbus-x11"
+
+EXTRA_OECONF = " --without-openldap --disable-gtk-doc --enable-gtk POLKIT_POLICY_FILE_VALIDATE=true"
+
+inherit autotools gettext
+
+EXTRA_OEMAKE = 'ORBIT_IDL="${ORBIT_IDL_SRC}"'
+
+do_install_append() {
+ # this directory need to be created to avoid an Error 256 at gdm launch
+ install -d ${D}${sysconfdir}/gconf/gconf.xml.system
+
+ # this stuff is unusable
+ rm ${D}${libdir}/GConf/*/*.*a
+}
+
+FILES_${PN} += "${libdir}/GConf/* \
+ ${datadir}/polkit* \
+ ${datadir}/dbus-1/services/*.service \
+ ${datadir}/dbus-1/system-services/*.service \
+"
+
+FILES_${PN}-dbg += "${libdir}/*/*/.debug"
+FILES_${PN}-dev += "${datadir}/sgml/gconf/gconf-1.0.dtd"
diff --git a/meta-oe/recipes-gnome/gnome/orbit2-2.14.17/configure-lossage.patch b/meta-oe/recipes-gnome/gnome/orbit2-2.14.17/configure-lossage.patch
new file mode 100644
index 0000000000..5fc1de5610
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2-2.14.17/configure-lossage.patch
@@ -0,0 +1,37 @@
+--- ORBit2-2.14.17/configure.in-orig 2009-01-10 09:36:18.000000000 -0800
++++ ORBit2-2.14.17/configure.in 2009-06-17 15:10:59.000000000 -0700
+@@ -217,20 +217,20 @@ dnl
+ dnl So many people with broken linking setups asked about this
+ dnl it turned out to be necessary to check for this.
+ dnl
+-dofus_save_libs="$LIBS"
+-LIBS="$ORBIT_LIBS $LIBS"
+-AC_TRY_RUN([ #include <stdio.h>
+- main ()
+- {
+- return 0;
+- } ],,
+- AC_MSG_ERROR([
+-Linking is badly borked on your system. Please ensure your library path is correct
+-Check config.log for details - check near the end of the log above 'failed program was'
+-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
+-prefix you're compiling on: '${prefix}' ]),
+-AC_MSG_WARN([Could not check for borked linking while cross-compiling]))
+-LIBS="$dofus_save_libs"
++dnl dofus_save_libs="$LIBS"
++dnl LIBS="$ORBIT_LIBS $LIBS"
++dnl AC_TRY_RUN([ #include <stdio.h>
++dnl main ()
++dnl {
++dnl return 0;
++dnl } ],,
++dnl AC_MSG_ERROR([
++dnl Linking is badly borked on your system. Please ensure your library path is correct
++dnl Check config.log for details - check near the end of the log above 'failed program was'
++dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
++dnl prefix you're compiling on: '${prefix}' ]),
++dnl AC_MSG_WARN([Could not check for borked linking while cross-compiling]))
++dnl LIBS="$dofus_save_libs"
+
+ orig_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
diff --git a/meta-oe/recipes-gnome/gnome/orbit2-native_2.14.12.bb b/meta-oe/recipes-gnome/gnome/orbit2-native_2.14.12.bb
new file mode 100644
index 0000000000..1db2496c35
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2-native_2.14.12.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "CORBA ORB"
+PR = "r0"
+LICENSE = "LGPL GPL"
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+SECTION = "x11/gnome/libs"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
+ file://configure-lossage.patch \
+ file://gtk-doc.m4 \
+ file://gtk-doc.make"
+DEPENDS = "libidl-native popt-native gtk-doc"
+
+S = "${WORKDIR}/ORBit2-${PV}"
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/orbit2"
+
+PARALLEL_MAKE = ""
+inherit autotools native pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+do_configure_prepend() {
+ mkdir -p m4
+ install ${WORKDIR}/gtk-doc.m4 ./m4/
+ install ${WORKDIR}/gtk-doc.make ./
+}
+
+SRC_URI[md5sum] = "6f4bf7d803d442e9d093a0daa203d506"
+SRC_URI[sha256sum] = "d60027a4a36e64d02723d00b76c08e8d92850cab6269b2edcda4a1bb30cc7723"
diff --git a/meta-oe/recipes-gnome/gnome/orbit2.inc b/meta-oe/recipes-gnome/gnome/orbit2.inc
new file mode 100644
index 0000000000..51978909be
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2.inc
@@ -0,0 +1,32 @@
+LICENSE = "GPL"
+DESCRIPTION = "CORBA ORB"
+SECTION = "x11/gnome/libs"
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/ORBit2/2.14/ORBit2-${PV}.tar.bz2 \
+ file://configure-lossage.patch \
+ file://pkgconfig-fix.patch \
+ file://gtk-doc.m4 \
+ file://gtk-doc.make"
+DEPENDS = "libidl popt orbit2-native gtk-doc"
+PARALLEL_MAKE = ""
+
+LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
+
+FILES_${PN} += "${libdir}/orbit-2.0/*.so"
+FILES_${PN}-dev += "${libdir}/orbit-2.0/*.a ${libdir}/orbit-2.0/*.la"
+FILES_${PN}-dbg += "${libdir}/orbit-2.0/.debug"
+
+S = "${WORKDIR}/ORBit2-${PV}"
+
+LEAD_SONAME = "libORBit-2.so"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-gtk-doc"
+EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
+
+do_configure_prepend() {
+ mkdir -p m4
+ install ${WORKDIR}/gtk-doc.m4 ./m4/
+ install ${WORKDIR}/gtk-doc.make ./
+}
+
diff --git a/meta-oe/recipes-gnome/gnome/orbit2/configure-lossage.patch b/meta-oe/recipes-gnome/gnome/orbit2/configure-lossage.patch
new file mode 100644
index 0000000000..7485a0ce0c
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2/configure-lossage.patch
@@ -0,0 +1,35 @@
+--- orbit/configure.in~ 2004-05-07 09:31:32.000000000 +0100
++++ orbit/configure.in 2004-05-08 19:27:35.000000000 +0100
+@@ -193,19 +193,19 @@
+ dnl So many people with broken linking setups asked about this
+ dnl it turned out to be necessary to check for this.
+ dnl
+-dofus_save_libs="$LIBS"
+-LIBS="$ORBIT_LIBS $LIBS"
+-AC_TRY_RUN([ #include <stdio.h>
+- main ()
+- {
+- return 0;
+- } ],,
+- AC_MSG_ERROR([
+-Linking is badly borked on your system. Please ensure your library path is correct
+-Check config.log for details - check near the end of the log above 'failed program was'
+-Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
+-prefix you're compiling on: '${prefix}' ]))
+-LIBS="$dofus_save_libs"
++dnl dofus_save_libs="$LIBS"
++dnl LIBS="$ORBIT_LIBS $LIBS"
++dnl AC_TRY_RUN([ #include <stdio.h>
++dnl main ()
++dnl {
++dnl return 0;
++dnl } ],,
++dnl AC_MSG_ERROR([
++dnl Linking is badly borked on your system. Please ensure your library path is correct
++dnl Check config.log for details - check near the end of the log above 'failed program was'
++dnl Alternatively ensure that your /etc/ld.so.conf (and/or LD_LIBRARY_PATH) includes the
++dnl prefix you're compiling on: '${prefix}' ]))
++dnl LIBS="$dofus_save_libs"
+
+ orig_CPPFLAGS=$CPPFLAGS
+ CPPFLAGS="$CPPFLAGS $ORBIT_CFLAGS"
diff --git a/meta-oe/recipes-gnome/gnome/orbit2/pkgconfig-fix.patch b/meta-oe/recipes-gnome/gnome/orbit2/pkgconfig-fix.patch
new file mode 100644
index 0000000000..f629e506dd
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2/pkgconfig-fix.patch
@@ -0,0 +1,12 @@
+diff -urN ORBit2-2.14.12.orig/ORBit-2.0.pc.in ORBit2-2.14.12/ORBit-2.0.pc.in
+--- ORBit2-2.14.12.orig/ORBit-2.0.pc.in 2008-01-29 13:45:22.000000000 +0100
++++ ORBit2-2.14.12/ORBit-2.0.pc.in 2008-09-23 20:13:07.000000000 +0200
+@@ -2,7 +2,7 @@
+ exec_prefix=@exec_prefix@
+ libdir=@libdir@
+ includedir=@includedir@
+-orbit_idl=@bindir@/orbit-idl-2@EXEEXT@
++orbit_idl=@exec_prefix@/bin/orbit-idl-2@EXEEXT@
+
+
+ Name: ORBit-2.0
diff --git a/meta-oe/recipes-gnome/gnome/orbit2_2.14.17.bb b/meta-oe/recipes-gnome/gnome/orbit2_2.14.17.bb
new file mode 100644
index 0000000000..47f632793c
--- /dev/null
+++ b/meta-oe/recipes-gnome/gnome/orbit2_2.14.17.bb
@@ -0,0 +1,5 @@
+require orbit2.inc
+
+
+SRC_URI[md5sum] = "10bfb957fa4a8935a0b4afaee7d71df7"
+SRC_URI[sha256sum] = "62bfce3f678f9347a19c766944e8aef7b89bc32b25ac23eb3e4c25929ce8974c"