aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-core/dbus/dbus-c++-native_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-core/dbus/dbus-c++-native_git.bb')
-rw-r--r--meta-oe/recipes-core/dbus/dbus-c++-native_git.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-core/dbus/dbus-c++-native_git.bb b/meta-oe/recipes-core/dbus/dbus-c++-native_git.bb
new file mode 100644
index 0000000000..eba80b2e9a
--- /dev/null
+++ b/meta-oe/recipes-core/dbus/dbus-c++-native_git.bb
@@ -0,0 +1,17 @@
+require dbus-c++_git.bb
+inherit native
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/dbus-c++"
+# actually dbus-native and expat-native, but even the bearest build machine should have that nowadays...
+DEPENDS = ""
+
+do_compile() {
+ oe_runmake -C src libdbus-c++-1.la
+ oe_runmake -C tools dbusxx-xml2cpp
+ install -m 0755 tools/dbusxx-xml2cpp ${STAGING_BINDIR_NATIVE}
+}
+
+do_install() {
+ :
+}
+