aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.5.bb')
-rw-r--r--meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.5.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.5.bb b/meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.5.bb
new file mode 100644
index 0000000000..bcfe646913
--- /dev/null
+++ b/meta-networking/recipes-connectivity/openfortivpn/openfortivpn_1.20.5.bb
@@ -0,0 +1,26 @@
+SUMMARY = "Client for PPP+SSL VPN tunnel services"
+LICENSE = "GPL-3.0-or-later"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3d575262a651a6f1a17210ce41bf907d"
+
+SRC_URI = "git://github.com/adrienverge/openfortivpn.git;protocol=https;branch=master"
+SRCREV = "1ccb8ee682af255ae85fecd5fcbab6497ccb6b38"
+
+DEPENDS = "openssl"
+
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+
+PACKAGECONFIG[resolvconf] = "--with-resolvconf=${base_sbindir}/resolvconf --enable-resolvconf,--with-resolvconf=DISABLED,,"
+PACKAGECONFIG[systemd] = "--with-systemdsystemunitdir=${systemd_system_unitdir},--without-systemdsystemunitdir,,"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig systemd
+
+EXTRA_OECONF = " \
+ --with-pppd=${sbindir}/pppd \
+ --disable-proc \
+"
+
+SYSTEMD_SERVICE:${PN} = "openfortivpn@.service"
+
+RDEPENDS:${PN} = "ppp"