aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/gnome-session/gnome-session_44.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/gnome-session/gnome-session_44.0.bb')
-rw-r--r--meta-gnome/recipes-gnome/gnome-session/gnome-session_44.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-session/gnome-session_44.0.bb b/meta-gnome/recipes-gnome/gnome-session/gnome-session_44.0.bb
new file mode 100644
index 0000000000..3f642f401f
--- /dev/null
+++ b/meta-gnome/recipes-gnome/gnome-session/gnome-session_44.0.bb
@@ -0,0 +1,38 @@
+SUMMARY = "GNOME session"
+LICENSE = "GPL-2.0-only"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
+
+DEPENDS = " \
+ glib-2.0-native \
+ libxslt-native \
+ xmlto-native \
+ xtrans \
+ libice \
+ libsm \
+ virtual/libx11 \
+ gtk+3 \
+ gnome-desktop \
+ gsettings-desktop-schemas \
+ json-glib \
+"
+
+GNOMEBASEBUILDCLASS = "meson"
+
+inherit gnomebase gettext gsettings upstream-version-is-even features_check
+
+REQUIRED_DISTRO_FEATURES = "x11 polkit systemd pam gobject-introspection-data"
+
+SRC_URI[archive.sha256sum] = "ccf829a96526135e9e9f917526515d36a5092bdfa316f3737dd8c5a524dbf2c6"
+
+PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', 'consolekit',d)}"
+
+PACKAGECONFIG[consolekit] = "-Dconsolekit=true, -Dconsolekit=false, dbus-glib"
+PACKAGECONFIG[systemd] = "-Dsystemd=true -Dsystemd_journal=true, -Dsystemd=false -Dsystemd_journal=false, systemd"
+
+FILES:${PN} += " \
+ ${datadir}/xsessions \
+ ${datadir}/wayland-sessions \
+ ${systemd_user_unitdir} \
+"
+
+RDEPENDS:${PN} += "gnome-shell gnome-settings-daemon gsettings-desktop-schemas"