aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-networking/recipes-devtools/python/python3-ldap_3.4.0.bb (renamed from meta-networking/recipes-devtools/python/python3-ldap_3.3.1.bb)13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta-networking/recipes-devtools/python/python3-ldap_3.3.1.bb b/meta-networking/recipes-devtools/python/python3-ldap_3.4.0.bb
index cd745ee3ee..42f113d5f8 100644
--- a/meta-networking/recipes-devtools/python/python3-ldap_3.3.1.bb
+++ b/meta-networking/recipes-devtools/python/python3-ldap_3.4.0.bb
@@ -1,22 +1,19 @@
-#
-# Copyright (C) 2012 Wind River Systems, Inc.
-#
SUMMARY = "Provides a wrapper in Python to LDAP"
DESCRIPTION = "This module provides access to the LDAP \
(Lightweight Directory Access Protocol) through Python operations \
instead of C API. The module mainly acts as a wrapper for the \
OpenLDAP 2.x libraries. Errors will appear as exceptions."
-
-LICENSE = "PSF"
HOMEPAGE = "http://www.python-ldap.org/"
+LICENSE = "PSF"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
+
DEPENDS = "python3 openldap cyrus-sasl"
PYPI_PACKAGE = "python-ldap"
+
inherit pypi setuptools3
-LIC_FILES_CHKSUM = "file://LICENCE;md5=36ce9d726d0321b73c1521704d07db1b"
-SRC_URI[md5sum] = "7608579722c491e42f5f63b3f88a95fb"
-SRC_URI[sha256sum] = "4711cacf013e298754abd70058ccc995758177fb425f1c2d30e71adfc1d00aa5"
+SRC_URI[sha256sum] = "60464c8fc25e71e0fd40449a24eae482dcd0fb7fcf823e7de627a6525b3e0d12"
do_configure:prepend() {
sed -i -e 's:^library_dirs =.*::' \