aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-devtools/gcc/libgcc_4.5.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-18 11:41:25 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-18 11:41:25 +0100
commit2414ce31087fa910437cae45703c3b13a5daf5a9 (patch)
treeb1c8a6c5307d020b963136d9823fed015844e5f2 /recipes-devtools/gcc/libgcc_4.5.bb
parent898fc9f4c9c9efbcd50ce53e29ad2fb54b09eb21 (diff)
downloadmeta-openembedded-contrib-2414ce31087fa910437cae45703c3b13a5daf5a9.tar.gz
gcc: import yocto rev 0df3c481309e89b93e8a57773eb9c470b4dd13a7
From: Dexuan Cui <dexuan.cui@intel.com> Date: Sat, 15 Jan 2011 10:47:50 +0000 Subject: libgcc: use the new recipe (rather than gcc-runtime) to install libgcc_s.so* and crt*.o Currently gcc-runtime installs the files, but actually gcc-runtime's do_configure checks if the files are available, so before we build gcc-runtime, we should have some recipe install the files first! -- currently gcc-cross-intermediate actually does that(gcc-cross also installs the files, but it installs into the gcc-build-internal* directory), but gcc-cross-intermediate will have its own sysroot in future, after that, gcc-runtime won't build. So let us add this new target recipe and move the installation of the files from gcc-runtime into it changed to apply to gcc 4.5 Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'recipes-devtools/gcc/libgcc_4.5.bb')
-rw-r--r--recipes-devtools/gcc/libgcc_4.5.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/recipes-devtools/gcc/libgcc_4.5.bb b/recipes-devtools/gcc/libgcc_4.5.bb
new file mode 100644
index 0000000000..a99fdeffd4
--- /dev/null
+++ b/recipes-devtools/gcc/libgcc_4.5.bb
@@ -0,0 +1,42 @@
+require gcc-${PV}.inc
+
+PR = "r0"
+
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+PACKAGES = "\
+ ${PN} \
+ ${PN}-dev \
+ "
+
+FILES_${PN} = "${base_libdir}/libgcc*.so.*"
+FILES_${PN}-dev = " \
+ ${base_libdir}/libgcc*.so \
+ ${libdir}/${TARGET_SYS}/${BINV}/crt* \
+ ${libdir}/${TARGET_SYS}/${BINV}/libgcc*"
+
+do_fetch[noexec] = "1"
+do_unpack[noexec] = "1"
+do_patch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+do_install () {
+ target=`echo ${MULTIMACH_TARGET_SYS} | sed -e s#-nativesdk##`
+
+ # Install libgcc from our gcc-cross saved data
+ install -d ${D}${base_libdir} ${D}${libdir}
+ cp -fpPR ${STAGING_INCDIR_NATIVE}/gcc-build-internal-$target/* ${D}
+
+ # Move libgcc_s into /lib
+ mkdir -p ${D}${base_libdir}
+ if [ -f ${D}${libdir}/nof/libgcc_s.so ]; then
+ mv ${D}${libdir}/nof/libgcc* ${D}${base_libdir}
+ else
+ mv ${D}${libdir}/libgcc* ${D}${base_libdir} || true
+ fi
+}
+
+BBCLASSEXTEND = "nativesdk"
+