aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorChase Qi <chase.qi@linaro.org>2023-07-27 12:06:27 +0100
committerKhem Raj <raj.khem@gmail.com>2023-07-27 08:54:40 -0700
commitfc0e3cb91ee35bdc9d8a4371b219040dae502697 (patch)
treec0ae8c4d5dba0a80b9337c02245e00bd40392b05 /meta-python
parent65f1009ced946707dce286792bf5118f2fec37e3 (diff)
downloadmeta-openembedded-contrib-fc0e3cb91ee35bdc9d8a4371b219040dae502697.tar.gz
meta-python: add python3-telnetlib3 package
telnetlib3 is a Telnet client and server library for python. Signed-off-by: Chase Qi <chase.qi@linaro.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-devtools/python/python3-telnetlib3_2.0.4.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-telnetlib3_2.0.4.bb b/meta-python/recipes-devtools/python/python3-telnetlib3_2.0.4.bb
new file mode 100644
index 0000000000..c7e650d943
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-telnetlib3_2.0.4.bb
@@ -0,0 +1,15 @@
+SUMMARY = "Telnet server and client library based on asyncio"
+HOMEPAGE = "https://github.com/jquast/telnetlib3"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=fc2166986ad8169d334a342e0d8db8e0"
+
+SRC_URI[md5sum] = "2dfac7e10ed63c408da50ea712415f87"
+SRC_URI[sha256sum] = "dbcbc16456a0e03a62431be7cfefff00515ab2f4ce2afbaf0d3a0e51a98c948d"
+
+PYPI_PACKAGE = "telnetlib3"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} = "\
+ ${PYTHON_PN}-asyncio \
+"