aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-07-25 10:15:56 -0400
committerKhem Raj <raj.khem@gmail.com>2023-07-25 08:43:53 -0700
commit2b488648deb7a21f4923a79be45167a820da013f (patch)
tree0e64deb8fd10fc2ecf6ea2b050e1e5d96447eee9 /meta-python
parent6804adf7b022e80dcd8913f7cd1c1fc2f72c9995 (diff)
downloadmeta-openembedded-contrib-2b488648deb7a21f4923a79be45167a820da013f.tar.gz
python3-send2trash: upgrade 1.8.0 -> 1.8.2
- Update build backend since they use a pyproject.toml file now. - Add python3-io to RDEPENDS so that the module can be imported. Changelog (https://github.com/arsenetar/send2trash/releases): 1.8.2 - Add fallback to HOMETRASH when cross device errors happen in plat_other (#26, #41, #63) - win/legacy: tiny logic simplification by @BoboTiG in #77 - TravisCI is not used anymore by @sobolevn in #73 - fix(ci): Update to latest actions, fix python versions by @arsenetar in #78 1.8.1b0 - Add fallback to HOMETRASH when cross device errors happen in plat_other (#26, #41, #63) Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python')
-rw-r--r--meta-python/recipes-extended/send2trash/python3-send2trash_1.8.2.bb (renamed from meta-python/recipes-extended/send2trash/python3-send2trash_1.8.0.bb)9
1 files changed, 6 insertions, 3 deletions
diff --git a/meta-python/recipes-extended/send2trash/python3-send2trash_1.8.0.bb b/meta-python/recipes-extended/send2trash/python3-send2trash_1.8.2.bb
index a20b0194f8..eac89e6297 100644
--- a/meta-python/recipes-extended/send2trash/python3-send2trash_1.8.0.bb
+++ b/meta-python/recipes-extended/send2trash/python3-send2trash_1.8.2.bb
@@ -2,10 +2,13 @@ SUMMARY = "Send file to trash natively under Mac OS X, Windows and Linux"
LICENSE = "BSD-3-Clause"
LIC_FILES_CHKSUM = "file://LICENSE;md5=a02659c2d5f4cc626e4dcf6504b865eb"
-inherit pypi setuptools3
+inherit pypi python_setuptools_build_meta
-SRC_URI[sha256sum] = "d2c24762fd3759860a0aff155e45871447ea58d2be6bdd39b5c8f966a0c99c2d"
+SRC_URI[sha256sum] = "c132d59fa44b9ca2b1699af5c86f57ce9f4c5eb56629d5d55fbb7a35f84e2312"
PYPI_PACKAGE = "Send2Trash"
-RDEPENDS:${PN} += "python3-datetime"
+RDEPENDS:${PN} += "\
+ python3-io \
+ python3-datetime \
+"