aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 09:28:37 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-04 07:22:16 -0700
commite8ed47d627d87fa1398408707831e06986be3cb7 (patch)
treeb43756fa2a54ded7e35627e1c6a26a85aa6c755b /meta-python/recipes-devtools
parent258e0d596357dcbc1fa968c70154666911fc213b (diff)
downloadmeta-openembedded-contrib-e8ed47d627d87fa1398408707831e06986be3cb7.tar.gz
python-waitress: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python-waitress.inc10
-rw-r--r--meta-python/recipes-devtools/python/python3-waitress_1.4.2.bb12
2 files changed, 11 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python-waitress.inc b/meta-python/recipes-devtools/python/python-waitress.inc
deleted file mode 100644
index 0c288d52ff..0000000000
--- a/meta-python/recipes-devtools/python/python-waitress.inc
+++ /dev/null
@@ -1,10 +0,0 @@
-SUMMARY = "A WSGI server for Python"
-DESCRIPTION = "Waitress is meant to be a production-quality pure-Python WSGI \
- server with very acceptable performance."
-HOMEPAGE = "https://github.com/Pylons/waitress"
-SECTION = "devel/python"
-LICENSE = "ZPL-2.1"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=78ccb3640dc841e1baecb3e27a6966b2"
-
-SRC_URI[md5sum] = "fdeed7ec32bbba011e90801208378c89"
-SRC_URI[sha256sum] = "67a60a376f0eb335ed88967c42b73983a58d66a2a72eb9009a42725f7453b142"
diff --git a/meta-python/recipes-devtools/python/python3-waitress_1.4.2.bb b/meta-python/recipes-devtools/python/python3-waitress_1.4.2.bb
index 83c8b66d82..257993f8fb 100644
--- a/meta-python/recipes-devtools/python/python3-waitress_1.4.2.bb
+++ b/meta-python/recipes-devtools/python/python3-waitress_1.4.2.bb
@@ -1,2 +1,12 @@
+SUMMARY = "A WSGI server for Python"
+DESCRIPTION = "Waitress is meant to be a production-quality pure-Python WSGI \
+ server with very acceptable performance."
+HOMEPAGE = "https://github.com/Pylons/waitress"
+SECTION = "devel/python"
+LICENSE = "ZPL-2.1"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=78ccb3640dc841e1baecb3e27a6966b2"
+
+SRC_URI[md5sum] = "fdeed7ec32bbba011e90801208378c89"
+SRC_URI[sha256sum] = "67a60a376f0eb335ed88967c42b73983a58d66a2a72eb9009a42725f7453b142"
+
inherit setuptools3 pypi
-require python-waitress.inc