aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools
diff options
context:
space:
mode:
authorTrevor Gamblin <tgamblin@baylibre.com>2023-07-24 15:44:26 -0400
committerKhem Raj <raj.khem@gmail.com>2023-07-24 20:24:26 -0700
commitb4dbeba98b262cb75da4ca0e954d814403d48662 (patch)
treecb718293481e9c56df928595e4e33bdc397dfb2c /meta-python/recipes-devtools
parent98f3ebfa0393c6fa7a5e334e3221161765749270 (diff)
downloadmeta-openembedded-contrib-b4dbeba98b262cb75da4ca0e954d814403d48662.tar.gz
python3-pandas: upgrade 1.5.3 -> 2.0.3
pandas now requires versioneer, so add that to the DEPENDS list. The LICENSE checksum changed but this was due to line endings and not a difference in content. Changelog: https://github.com/pandas-dev/pandas/releases Signed-off-by: Trevor Gamblin <tgamblin@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools')
-rw-r--r--meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb (renamed from meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb)8
1 files changed, 5 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb b/meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb
index 129c3147cf..87a173c8a2 100644
--- a/meta-python/recipes-devtools/python/python3-pandas_1.5.3.bb
+++ b/meta-python/recipes-devtools/python/python3-pandas_2.0.3.bb
@@ -4,14 +4,16 @@ high-performance, easy-to-use data structures and data analysis tools for \
the Python programming language."
HOMEPAGE = "http://pandas.pydata.org/"
LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=c1cc9ab35a8b2aabf933cd6d245b5db3"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cb819092901ddb13a7d0a4f5e05f098a"
-SRC_URI[sha256sum] = "74a3fd7e5a7ec052f183273dc7b0acd3a863edf7520f5d3a1765c04ffdb3b0b1"
+SRC_URI[sha256sum] = "c02f372a88e0d17f36d3093a644c73cfc1788e876a7c4bcb4020a77512e2043c"
inherit pypi setuptools3
DEPENDS += " \
- ${PYTHON_PN}-numpy-native ${PYTHON_PN}-cython-native \
+ ${PYTHON_PN}-cython-native \
+ ${PYTHON_PN}-numpy-native \
+ ${PYTHON_PN}-versioneer-native \
"
PACKAGESPLITFUNCS =+ "fix_cythonized_sources"