aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2021-01-20 13:10:27 +0200
committerKhem Raj <raj.khem@gmail.com>2021-01-25 14:34:06 -0800
commit21b28425177943e96f50e322fe97007ea9b3a160 (patch)
tree8e37b340b07c0466f0dddbaaf66c21a1ee48f4c3 /meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
parent220d63cbc50fc54759e278727eee474b6d779a47 (diff)
downloadmeta-openembedded-contrib-21b28425177943e96f50e322fe97007ea9b3a160.tar.gz
python3-pyserial: Upgrade 3.4 -> 3.5
Upgrade to release 3.5: - iAdd a backend for Silicon Labs CP2110/4 HID-to-UART bridge. (depends on hid module) - Use absolute import everywhere - win32: miniterm Working CMD.exe terminal using Windows 10 ANSI support - Make ListPortInfo hashable - threaded: "write" returns byte count - Add bytesize and stopbits argument parser to tcp_serial_redirect - loop: add out_waiting - list_ports_linux: Correct "interface" property on Linux hosts - Remove Python 3.2 and 3.3 from test - doc updates - miniterm: add CTRL+T Q as alternative to exit - miniterm: suspend function key changed to CTRL-T Z - add command line tool entries pyserial-miniterm (replaces miniterm.py) and pyserial-ports (runs serial.tools.list_ports). - python -m serial opens miniterm (use w/o args and it will print port list too) [experimental] - Don't open port if self.port is not set while entering context manager - refactor: raise new instances for PortNotOpenError and SerialTimeoutException - list_ports: set default name attribute - fix: compare only of the same type in list_ports_common.ListPortInfo - rfc2217/close(): fix race-condition - return b'' when connection closes on rfc2217 connection - rfc2217/close(): fix race condition - Fixed flush_input_buffer() for situations where the remote end has closed the socket. - reset_input_buffer() can hang on sockets - examples: port_publisher python 3 fixes - miniterm: Fix miniterm constructor exit_character and menu_character - miniterm: use exclusive access for native serial ports by default - miniterm: fix double use of CTRL-T + s use z for suspend instead - examples: refactor wx example, use Bind to avoid deprecated warnings, IsChecked, unichr - posix: fix PosixPollSerial with timeout=None and add cancel support - option for low latency mode on linux - Add support to xr-usb-serial ports - posix: Don't catch the SerialException we just raised - posix: Fix custom baud rate to not temporarily set 38400 baud rates on linux - list_ports: use hardcoded path to library on osx Following the rename of miniterm.py and the new command line tool entry, task do_install_append has been updated accordingly. License-Update: Update year Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pyserial_3.4.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pyserial_3.4.bb62
1 files changed, 0 insertions, 62 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb b/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
deleted file mode 100644
index d65c9a88b8..0000000000
--- a/meta-python/recipes-devtools/python/python3-pyserial_3.4.bb
+++ /dev/null
@@ -1,62 +0,0 @@
-SUMMARY = "Serial Port Support for Python"
-LICENSE = "BSD-3-Clause"
-LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=d476d94926db6e0008a5b3860d1f5c0d"
-
-SRC_URI[md5sum] = "ed6183b15519a0ae96675e9c3330c69b"
-SRC_URI[sha256sum] = "6e2d401fdee0eab996cf734e67773a0143b932772ca8b42451440cfed942c627"
-
-inherit pypi setuptools3 ptest
-
-do_install_append() {
- rm -f ${D}${bindir}/miniterm.py
- rmdir ${D}${bindir}
-}
-
-PACKAGES =+ "${PN}-java ${PN}-osx ${PN}-win32 ${PN}-tools"
-
-FILES_${PN}-java = " \
- ${PYTHON_SITEPACKAGES_DIR}/serial/*java* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/__pycache__/*java* \
-"
-
-FILES_${PN}-osx = " \
- ${PYTHON_SITEPACKAGES_DIR}/serial/tools/*osx* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/tools/__pycache__/*osx* \
-"
-
-FILES_${PN}-win32 = " \
- ${PYTHON_SITEPACKAGES_DIR}/serial/*serialcli* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/__pycache__/*serialcli* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/*win32* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/__pycache__/*win32* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/tools/miniterm* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/tools/__pycache__/miniterm* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/tools/*windows* \
- ${PYTHON_SITEPACKAGES_DIR}/serial/tools/__pycache__/*windows* \
-"
-
-RDEPENDS_${PN} = "\
- ${PYTHON_PN}-fcntl \
- ${PYTHON_PN}-io \
- ${PYTHON_PN}-logging \
- ${PYTHON_PN}-netclient \
- ${PYTHON_PN}-numbers \
- ${PYTHON_PN}-shell \
- ${PYTHON_PN}-stringold \
- ${PYTHON_PN}-threading \
-"
-
-BBCLASSEXTEND = "native nativesdk"
-
-SRC_URI += " \
- file://run-ptest \
-"
-
-RDEPENDS_${PN}-ptest += " \
- ${PYTHON_PN}-pytest \
-"
-
-do_install_ptest() {
- install -d ${D}${PTEST_PATH}/test
- cp -rf ${S}/test/* ${D}${PTEST_PATH}/test/
-}