aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-ptyprocess_0.6.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-19 11:10:11 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-22 08:38:15 -0700
commit50cd88ed6bb34f95589176e01269467db86089d2 (patch)
tree42ead3ce7d7fa453476a40f6ff240228c1e6b4e2 /meta-python/recipes-devtools/python/python3-ptyprocess_0.6.0.bb
parent502048818daa8bc755db6213b677c83636ba569b (diff)
downloadmeta-openembedded-contrib-50cd88ed6bb34f95589176e01269467db86089d2.tar.gz
python3-ptyprocess: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-ptyprocess_0.6.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-ptyprocess_0.6.0.bb43
1 files changed, 42 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-ptyprocess_0.6.0.bb b/meta-python/recipes-devtools/python/python3-ptyprocess_0.6.0.bb
index bdcd0e2539..87911e02e5 100644
--- a/meta-python/recipes-devtools/python/python3-ptyprocess_0.6.0.bb
+++ b/meta-python/recipes-devtools/python/python3-ptyprocess_0.6.0.bb
@@ -1,2 +1,43 @@
-require python-ptyprocess.inc
+SUMMARY = "Run a subprocess in a pseudo terminal"
+HOMEPAGE = "http://ptyprocess.readthedocs.io/en/latest/"
+SECTION = "devel/python"
+LICENSE = "ISC"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=cfdcd51fa7d5808da4e74346ee394490"
+
+SRCNAME = "ptyprocess"
+
+SRC_URI[md5sum] = "37402d69f3b50913d4d483587bffad8f"
+SRC_URI[sha256sum] = "923f299cc5ad920c68f2bc0bc98b75b9f838b93b599941a6b63ddbc2476394c0"
+
inherit pypi setuptools3
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/ptyprocess"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+RDEPENDS_${PN} = "\
+ ${PYTHON_PN}-core \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-resource \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+
+inherit ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+ ${PYTHON_PN}-fcntl \
+ ${PYTHON_PN}-terminal \
+ ${PYTHON_PN}-resource \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}