aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-luma-core_2.0.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-11-26 13:22:09 +0200
committerKhem Raj <raj.khem@gmail.com>2020-11-27 11:54:04 -0800
commitda677455b40b63a3d32d79bafada771b4b1144e1 (patch)
treec81a39be5121ff12ecd541002bf2629e5deb1340 /meta-python/recipes-devtools/python/python3-luma-core_2.0.1.bb
parent24517fa18bd5541630dea78dcc4d12963355c76d (diff)
downloadmeta-openembedded-contrib-da677455b40b63a3d32d79bafada771b4b1144e1.tar.gz
python3-luma-core: Upgrade 1.17.3 -> 2.0.1
Upgrade to release 2.0.1: - Improved diff_to_previous framebuffer performance - Add Linux framebuffer pseudo-device - Allow a wider range of SPI bus speeds - Fix to allow cmdline args to dynamically create a full_frame() instance Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-luma-core_2.0.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-luma-core_2.0.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-luma-core_2.0.1.bb b/meta-python/recipes-devtools/python/python3-luma-core_2.0.1.bb
new file mode 100644
index 0000000000..fad7432132
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-luma-core_2.0.1.bb
@@ -0,0 +1,19 @@
+SUMMARY = "A component library to support SBC display drivers"
+DESCRIPTION = "A component library to support SBC display drivers"
+HOMEPAGE = "https://github.com/rm-hull/luma.core"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=db07e3d471938ea7d7fd2135f88ac9a1"
+
+inherit pypi setuptools3
+
+SRC_URI[sha256sum] = "a0bc18c03cfb293c9c1b1d8883c2ec7c29d167e4af99f795b5698c8a864332df"
+
+CLEANBROKEN = "1"
+
+PYPI_PACKAGE = "luma.core"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pillow \
+ ${PYTHON_PN}-threading \
+ ${PYTHON_PN}-smbus2 \
+"