aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2021-08-23 16:11:48 -0700
committerTim Orling <timothy.t.orling@intel.com>2021-10-05 17:33:37 +0000
commit1f8bfd9d427cc4b40641ca92fe6b0447b527dcf3 (patch)
tree52ecd1320475215db0e0aa839a7556a1af321da8 /meta-python/recipes-devtools/python/python3-cryptography/h-test.patch
parentd2274628c0463b57a3d0578dfb6b62560dd5b22e (diff)
downloadmeta-openembedded-contrib-timo/rust_python3-cryptography.tar.gz
python3-cryptography: upgrade 3.3.2 -> 3.4.8timo/rust_python3-cryptography
Add PSF-2.0 license and explicitly add checksums for the LICENSE files that are packaged. RDEPENDS on python3-hypothesis (in oe-core) for ptest so we can drop the patch for skipping. DEPENDS on python3-setuptools-rust-native RDEPENDS on python3-pytest-subtests for ptest Need to inherit cargo, otherwise build_rust will fail to detect Rust compiler. Also, so that RUST_TARGET_PATH is exported, otherwise build_rust will fail because 'rustc --print cfg' doesn't know where the target specifications are. Copy pyproject.toml for ptest as it defines the pytest.marker(s) needed Cleanup and alphabetize the RDEPENDS Inherit python3-dir for the -dbg files for hazmat. Export PYO3_CROSS_LIB_DIR, PYO3_CROSS_INCLUDE_DIR and CARGO_BUILD_TARGET to inform setuptools-rust we are cross-compiling. Export RUSTFLAGS so cargo can find 'std' and 'core' for target Need to call cargo_common_do_configure to setup cargo_home/config so that the linker properly finds e.g. crti.o and crtbeginS.o However, bitbake vendoring does not appear to work with setuptools-rust, as it errors out immediately because it cannot find package pyo3: CARGO_DISABLE_BITBAKE_VENDORING = "1" FIXME: on qemux86-musl, do_install tries to rebuild Signed-off-by: Tim Orling <ticotimo@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography/h-test.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/h-test.patch10
1 files changed, 0 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch b/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch
deleted file mode 100644
index 9f07c73803..0000000000
--- a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/tests/hypothesis/__init__.py
-+++ b/tests/hypothesis/__init__.py
-@@ -3,3 +3,7 @@
- # for complete details.
-
- from __future__ import absolute_import, division, print_function
-+
-+import pytest
-+hypothesis = pytest.importorskip("hypothesis")
-+