aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pycodestyle_2.5.0.bb
diff options
context:
space:
mode:
authorYuan Chao <yuanc.fnst@cn.fujitsu.com>2019-08-02 08:59:28 +0800
committerKhem Raj <raj.khem@gmail.com>2019-08-02 18:04:41 -0700
commitf16db652876c869df9ec7e6ca350c67a66ee9297 (patch)
tree911f2a81aa57c1a4c2b471f5815abe7761b5ee8e /meta-python/recipes-devtools/python/python-pycodestyle_2.5.0.bb
parent91470d948cad7c2e769ba718f9a68ac5755016e1 (diff)
downloadmeta-openembedded-contrib-f16db652876c869df9ec7e6ca350c67a66ee9297.tar.gz
python-pycodestyle: upgrade 2.4.0 -> 2.5.0
Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pycodestyle_2.5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-pycodestyle_2.5.0.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycodestyle_2.5.0.bb b/meta-python/recipes-devtools/python/python-pycodestyle_2.5.0.bb
new file mode 100644
index 0000000000..ec6c12f2f1
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-pycodestyle_2.5.0.bb
@@ -0,0 +1,10 @@
+inherit setuptools
+require python-pycodestyle.inc
+
+RDEPENDS_${PN} += "${PYTHON_PN}-lang"
+
+do_install_append () {
+ if [ -f ${D}${bindir}/pycodestyle ]; then
+ mv ${D}${bindir}/pycodestyle ${D}${bindir}/pycodestyle-2
+ fi
+}